Support » Fixing WordPress » Numerous Google Soft 404 302 Found errors after HTTPS

  • This is really a Hail Mary query in the event anyone else has been having similar problems and can offer clues.

    I recently transitioned my WordPress site from http to https. SSL certificate from LetsEncrypt all in order. WordPress Address and Site Address both changed to https. All internal database references converted to https. Green padlock through and through.

    Since then Google has repeatedly been picking up Soft 404 errors in the form of 302 Found redirects to the home page, although I have not created any in .htaccess or elsewhere, for example, such as removed and now 404 page references being redirected to the home page per bad SEO advice.

    The pages referenced are perfectly good, live pages which return perfectly normal 200 codes, without redirects, when checked with a variety of header checkers. It is Googlebot alone which is claiming these pages “should” be 404s, and it seems to be the case that Googlebot alone is seeing the 302 Found redirect to Location: / and no one else, not browsers nor other header checkers.

    A number of these also happen to be the comment-page-1 problems which I understand are currently in the WordPress shop being addressed pending a future update.

    Anything anyone who has experienced something similar could shed on this phenomenon would be appreciated. TIA.

Viewing 3 replies - 1 through 3 (of 3 total)
  • @saintandrews,

    Without example links and/or screenshots etc its impossible to diagnose.

    You can research what HTTP headers are being sent though:

    http://web-sniffer.net

    Any HTTP to HTTPS 301’ing should take place on the server level, and not just within a WordPress database or PHP/header code.

    Thread Starter saintandrews

    (@saintandrews)

    Thanks, Jesse,

    Yes, I realize that the number of variables involved is daunting; that’s my problem. I’m really hoping for someone who has had a similar problem or a conceptual hint of what to look for as the culprit or both.

    The typical redirected header from Googlebot looks like this:

    Fetching
    Downloaded HTTP response:
    HTTP/1.1 302 Found
    Date: Sun, 13 Mar 2016 00:16:20 GMT
    Server: Apache
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Link: <https://www.aleksandreia.com/wp-json/>; rel="https://api.w.org/", <https://www.aleksandreia.com/?p=53114>; rel=shortlink
    X-Frame-Options: SAMEORIGIN
    Location: /
    Cache-Control: max-age=1, private, must-revalidate
    Vary: Accept-Encoding
    Content-Type: text/html; charset=UTF-8
    Content-Length: 784
    Keep-Alive: timeout=2, max=99
    Connection: Keep-Alive

    while, as I said, at the same time the link in question looks to any number of header checkers, not just Web-Sniffer, as a perfectly normal 200 page. Googlebot’s own simultaneous entry in my logs is also a normal 200 response.

    Contrary to what the Googlebot header says above, I am in fact using the Day and name pretty permalink setting and have been doing so for years.

    I’ve had intriguing hints about this problem from a number of places. One, that it might be associated with a canonicalization problem, as discussed and apparently resolved here

    https://wordpress.org/support/topic/ssl-certificate-6?replies=12

    I use that same canonicalization block.

    Another, that it might be associated with either dynamically generated WordPress pages (WebmasterWorld) and another that it might be associated with the WordPress API.

    Another that it might be Googlebot arbitrarily judging what it regards as “thin content” as “should be 404” pages whose 200 response is thereby erroneous in its little robot eyes; again, that 302 Found redirect only occurs within Google’s “Fetch as” and not without. I’ve asked Barry Schwarz of SERoundtable about this and he said he’d look into it.

    Further, out of hundreds of pages being crawled daily, only a relatively small number – dozens – are being flagged this way, so that suggests that this isn’t a fundamental flaw like a site-breaking script error but rather something more selective.

    Given the lag in Google’s GSC/WMT reporting, there’s no way to assess cause and effect by turning things off and on short term.

    So, because this seems like the sort of generic problem that could happen to any other WordPress – Google GSC user, again, I’m hoping for a Sherlockian pointer to a solution deduced from hopefully other instances or partial instances of the same thing.

    tyresekagame

    (@tyresekagame)

    what do i do with the HTTP response from google?
    i have found the unfamiliar codes but i dont know what to do with them,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Numerous Google Soft 404 302 Found errors after HTTPS’ is closed to new replies.