Support » Plugin: Toolset Types - Custom Post Types, Custom Fields and Taxonomies » numeric-fix.js dependency error

  • Resolved piwel

    (@piwel)


    Hi,

    I noticed there is a problem with dependencies of the JavaScript numeric-fix.js : it does not only depend from jQuery, but also from jQuery.validate.

    If this script is loaded before the validation script (which was the case on my installation, I don’t know why), an error occurs and breaks the whole JS loading as it’s not encapsulated.

    To fix it, just edit line 85 of file types/library/toolset/types/embedded/includes/fields/numeric.php with :

    wp_enqueue_script( 'wpcf-numeric',
                    WPCF_EMBEDDED_RES_RELPATH
                    . '/js/numeric_fix.js', array('wptoolset-form-jquery-validation'), WPCF_VERSION );

    Thanks for this plugin really useful, and by advance for the global fix 🙂

Viewing 1 replies (of 1 total)
  • Plugin Author Christian

    (@christianglingener)

    Hi piwel,

    nice catch, we will include your fix in the upcoming release.

    Thank you,
    Christian

Viewing 1 replies (of 1 total)
  • The topic ‘numeric-fix.js dependency error’ is closed to new replies.