Support » Plugin: footnotes » Numbers in reference container not aligned with footnote

  • Resolved dreadpiratebonney

    (@dreadpiratebonney)


    First, THANK YOU for a fantastic plugin! I’ve been using this plugin for several months on my site and it has worked wonderfully.

    I’m testing a new theme (Virtue Theme) and this is where the trouble comes in. Footnotes still functions perfectly, but in the references container, the footnote number is not aligned with the first line of the footnote, instead, it is centered vertically. So, say the footnote is 5 lines long, the #) would align with line 3. A picture is worth a thousand words:

    http://www.iccoalitiontest.org/missouri/

    I have some ridiculously long footnotes, so this makes it really hard to see where one begins and the next one ends.

    Is there a way to modify this with CSS? I am using the most current versions of WP and the Footnotes plugin.

    Thanks!

    https://wordpress.org/plugins/footnotes/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    ups. That’s a mistake since version 1.5.0 I guess. The reference container uses a table in the background and by default the vertical align is set to the middle of the cell.
    You can easily prevent this by editing the CSS.

    table.footnote-reference-container > tbody > tr > td { vertical-align: top; }

    I will fix that in the next release version too for other users.

    Hi dreadpiratebonney,

    we have published a new version (1.5.3) right now. Your issue is fixed now. The position of the cell content is set to top.

    You rock! Thank you!

    still not work for my wp

    link 1

    link 2

    but at this posting works fine

    link footnote works fine

    do you know why?

    They all look properly aligned to me. Try clearing your cache. Initially I had the same issue, but that solved it. 🙂

    Wow, great to see so many footnotes on your website!

    All these footnotes and their index appear correctly in my web browser (align top).
    As dreadpiratebonny wrote try to clear any WordPress cache (if you are using a WordPress caching Plugin like ‘WP Super Cache’) and clear the cache of your browser.
    Hope that solves your issue.

    (And don’t forget to write a review.)

    I have clear caching with WP super cache, and clear cache of my browser with cc cleaner. Nothing happen.

    If I open the site with chrome, If I click the footnote mark it is just not align top but If I open the site with IE and mozilla the footnote mark is not working. 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Numbers in reference container not aligned with footnote’ is closed to new replies.