WordPress.org

Forums

[closed] number_format() & Illegal string offset 'count' errors kills Add New Plugins (9 posts)

  1. lim2me
    Member
    Posted 1 year ago #

    Updated a WP site from 3.5.2 to 3.7.1. Now when I go to Plugins > Add New, a list of errors appear (modified to remove installation directory):

    Warning: Illegal string offset 'name' in [INSTALL_DIR]/wp-admin/includes/plugin-install.php on line 147
    
    Warning: Illegal string offset 'name' in [INSTALL_DIR]/wp-admin/includes/plugin-install.php on line 148
    
    Warning: Illegal string offset 'name' in [INSTALL_DIR]/wp-admin/includes/plugin-install.php on line 149
    
    Warning: Illegal string offset 'name' in [INSTALL_DIR]/wp-admin/includes/plugin-install.php on line 150
    
    Warning: Illegal string offset 'name' in [INSTALL_DIR]/wp-admin/includes/plugin-install.php on line 151

    The above block appears 13 times, after which the following error appears 5 times:

    Warning: number_format() expects parameter 1 to be double, string given in [INSTALL_DIR]/wp-includes/functions.php on line 155

    When I rolled back to 3.5.2 the error disappeared.

    I have tried disabling (even deleting) all plugins, using TwentyThirteen as the theme and even reinstalling WordPress (via Dashboard > Updates > Re-install Now) but the problem persists.

    I've updated other websites to 3.7.1 without any problem, not sure why this particular one is being such a bother.

  2. Guillaume ANJOU
    Member
    Posted 1 year ago #

    Same for me :(

  3. Guillaume ANJOU
    Member
    Posted 1 year ago #

    Adding that to wp-config.php makes it work but do not solve the problem, just hide it...

    define('WP_DEBUG', false);
    ini_set( 'display_errors', 'false' );
    ini_set( 'error_reporting', E_NONE );
  4. btlewand
    Member
    Posted 1 year ago #

    Same here. Only having an issue on a website I copied over to a new subdirectory as a development site. I probably haven't tried to search plugins for a number of days so problem could have been around awhile and am wondering if there is something in my database that is interfering with connecting to wordpress.org since the database was copied over a few weeks back. Reinstalled wp 3.71 and no change. Also turned plugins on and off. No change there either.

  5. station8
    Member
    Posted 1 year ago #

    I'm getting the number_format warning as well. I have both auto re-installed and manually re-installed WP 3.71 with no luck. Turned off and deleted all plugins and in conjunction, reverted to 2013, 2012, and 2011 themes with no luck.

    I'm glad to hear others are seeing this as well, but mysterious errors like this always make me nervous.

    If anyone has any insight, I'd love to hear it.

    Thanks!

  6. niclewis
    Member
    Posted 1 year ago #

    me too. i had a strange issue with SendPress plugin, and after deactiivating/deleting another plugin (simple twitter feed) the issue with Sendpress resolved...but the problem you are talking about has cropped up and won't go away.

    If this helps some here is my post about the problem with Sendpress
    http://wordpress.org/support/topic/cant-change-double-opt-in-message?replies=4#post-4949159

    A workaround seems to be just downloading plugins, then uploading vs the search plugin feature.

  7. inveress
    Member
    Posted 1 year ago #

    Hi all,

    Same problem for me: the string offset error and the number format error on one site; just the number format error on another. Both upgraded to 3.7.1 recently.

    Where it normally displays plugin tags at the bottom of the Add Plugin page it seems to be displaying only the first letters, or something... I've had a quick play with the PHP behind it to try and get some more info but haven't had time to do a thorough job yet.

    Wondering if it's to do with the version of PHP running... I'm on 5.3.19. Anyone else got their version numbers handy?

    Peter.

  8. station8
    Member
    Posted 1 year ago #

    @inveress I'm running PHP 5.3.22.

    And I might be wrong, but I swear I update to WP 3.7.1 and lived with it a few days without the warning. That's why I was sure it was a recently added plugin. But deactivating and even removing them did nothing.

    Right now it's just an inconvience. I just hope it isn't on my end I'm missing.

  9. WPyogi
    Forum Moderator
    Posted 1 year ago #

    FWIW, here's a thread with this error mentioning PHP verions -

    http://wordpress.org/support/topic/network-dashboard-functionsphp-error?replies=27

Topic Closed

This topic has been closed to new replies.

About this Topic