WordPress.org

Forums

WP VeriteCo Timeline
[resolved] Number of timeline posts (22 posts)

  1. rmorson
    Member
    Posted 1 year ago #

    I am using your wordpress plugin WP VeriteCo Timeline, and a theme. I have set my posts to show above the number of actual timeline posts I have (40 timeline items).

    However, I still ONLY GET the ten most recent posts showing in the timeline.

    I am using [WPVT] as the shortcode for the timeline placement on the page.

    Am I doing something wrong, or is there somewhere in the plugin where I can actually set the number of posts for the timeline to go beyond 10. I have edited the settings for reading and post display settings in the theme. I also tested the plugin using the default wordpress theme (Twenty Thirteen), using 100 post as my reading settings and still I get only 10 posts in the timeline.

    I really need help to figure out what I'm doing wrong. Is it the short code? Please help urgently.

    Thanks
    rmorson

    http://wordpress.org/plugins/wp-veriteco-timeline/

  2. luis_castilho
    Member
    Posted 1 year ago #

    Not sure if you still need help with this but... this magic number is actually the number of posts Worpress is set to show per page. Doesn't make sense to me but at least it's easy to fix.

    Go to Settings > Reading and set "Blog pages show at most" to how many timeline entries you want to show. Set this option to 1000 or whatever if you want to show all entries.

  3. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    FYI, I have adopted this plugin and will be pushing out some fixes as soon as I am able. Adding an option to set the number of timeline posts is on the list, probably for version 1.2 as soon as I take care of the critical fixes.

    I've set up a GitHub repo for the plugin: https://github.com/jjeaton/wp-veriteco-timeline/

    Please add any additional issues there.

  4. Annekee
    Member
    Posted 1 year ago #

    I have the same problem, exactly 10 (last) entries showing up, and 10 in the json file. But I have 22 entries. Changing the number of posts in the WP settings doesn't help. Can you perhaps provide a fix or a change in the code somewhere? I would really regret changing to another timeline...

  5. Annekee
    Member
    Posted 1 year ago #

    I fixed it myself. Look up in wp-veriteco-timeline.php, around line 354:

    $last = ($loop->post_count <= get_option('posts_per_page')) ? $loop->post_count : get_option('posts_per_page');

    Change this to:

    $post_count = -1; // minus one = show all, or enter your max number
    $last = $loop->post_count;

    Clear cache and reload. No guarantees, but it worked for me.

  6. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    Version 1.2 should have a fix for this, I'm currently working on it.

  7. ravimevcha
    Member
    Posted 1 year ago #

    Below solution doesn't work for me.

    $post_count = -1; // minus one = show all, or enter your max number
    $last = $loop->post_count;

    Josh,

    It would be great it if you can tell us when the next version will be available with this fix.

  8. Annekee
    Member
    Posted 1 year ago #

    ravimevcha, after that you could try emtying your cache and reload. I had to empty and reload several times before it worked.

  9. ravimevcha
    Member
    Posted 1 year ago #

    Annekee, I tried multiple time, even on different machine where I was opening site for first time, still it shows only last 10 entries.

    Is there any other way to solve it?

  10. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    This is the workaround I've used before:

    line 352:

    Change:

    $args = array( 'post_type' => 'timeline' );
    

    to

    $args = array( 'post_type' => 'timeline', 'nopaging' => true );
    

    to show all posts. To limit to a certain number, say 25 posts, change it to this:

    $args = array( 'post_type' => 'timeline', 'posts_per_page' => 25 );
    

    I will update this to allow you the option to change it in the admin, I just have so much client work right now it's hard to find the time.

  11. ravimevcha
    Member
    Posted 1 year ago #

    Thanks a lot Josh. It's working now. I can see all the timeline instead of just 10.

    many thanks..

  12. rmorson
    Member
    Posted 1 year ago #

    You know I've tried just about everything, but now I just get "parsing data and it keeps spinning. Nothing is actually showing anymore, even after I put it back to the original.

    What could be wrong?

  13. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    @rmorson

    If you have any HTML (links, etc.) in your timeline posts, it will break.

    As a quick fix you could try changing line 360:

    $string .= stripslashes($entry->toJSON());
    

    to:

    $string .= $entry->toJSON();
    

    and then resave one of the timeline posts so that it rebuilds the JSON file.

  14. rmorson
    Member
    Posted 1 year ago #

    I even created a new timeline post, and well, here I am still seeing a spinning "parsing data" instead of my timeline.

    I don't believe I have html in my timeline posts though. I kept them simple.

    Ugh. So disappointing.

  15. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    @rmorson, do you have a link to the site I can see?

  16. rmorson
    Member
    Posted 1 year ago #

    http://www.mcctoronto.com/history is the page where I have the timeline.

    (If necessary I am happy to email you login info or ftp info privately to get this sorted out)

    Thanks

  17. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    Version 1.1.1 has been released which changes it to pull all timeline posts.

    @rmorson, the Timeline JS has been updated as well, please upgrade the plugin and see if that resolves your issue.

  18. rmorson
    Member
    Posted 1 year ago #

    I have updated the plugin and now I just get a spinning "loading timeline" message. Ugh.

    Check the url I provided in previous post.

    Still not loading.

  19. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    @rmorson, something else on your site is affecting the plugin, there are other JavaScript errors, see this screenshot. Something relating to a MiniAudioPlayer seems to be the issue.

    https://dl.dropboxusercontent.com/s/ykmz9dcfdpm9su2/2014-03-15%20at%2012.02%20AM.png

  20. rmorson
    Member
    Posted 1 year ago #

    I turned off the plugin, and still nothing.

    When I inspect page etc, like your image I get:

    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (nothing, line 0) source: http://www.mcctoronto.com/nothing?callback=onJSONP_Data

    The timeline loading just spins still.

    rmorson

  21. Josh Eaton
    Member
    Plugin Author

    Posted 1 year ago #

    There's still something else failing before the timeline script loads.

    Uncaught SyntaxError: Unexpected end of input.

    It looks like it's something with your theme. If you switch to a default theme, the timeline works, yes? Something the theme is doing is breaking and conflicting with the plugin.

  22. rmorson
    Member
    Posted 1 year ago #

    Josh,

    The timeline does NOT works with a any default themes. I had already checked that.

    I shut off plugins one at a time until it worked. Turns out Lightbox Plus ColorBox plugin is the culprit and conflicts.

    It works if I deactivate that plugin!

    Yay.

    THanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic