Support » Theme: Morphology Lite » number of posts per page seems NOT editable in Morphology light version

  • Resolved Guinea Pig

    (@gjwmvg)


    Dear mrs / sir,

    I tried many times to change the number of posts per page in the Morphology lite-version ( ‘Settings’ > ‘Blog Options’ > ‘Image Post Template Count’ ) as descripted in the online instruction but after ALWAYS 10 posts the massage ‘OLDER POSTS’ appeared at the bottom ( even with different browsers – so not a browser issue – ). In the support for the light version i saw more people had this same problem ( like hemispare, 2 years and 10 months ago – topic : İmage Post 3×4 problem ).

    I searched in the php-sources to find out where the changes took places. It took me a few days but i was not able to find the cause of the problem. I changed many times the layout of the posts until there was only one option, changing the number in field ‘Image Post Template Count’ did not work.

    So i looked in the database. I found the table ‘wp_options’ with field number 22 ‘posts_per_page’. This field was filled with ’10’. After changing this into ’12’ i directly got 12 tiles at my blog as it should be. Changing the field in ‘4’ i got directly 4 tiles. So it seems this field was not update when changing the ‘Image Post Template Count’ field.

    My question : is it possible there will be an update for the Morphology lite version so changes of the field ‘Image Post Template Count’ will be accepted ? This might be very helpful for many people who like this WordPress theme ( like me ). I don’t like to do changes directly in the database.

    Thanks in advanced
    Bert van Giersbergen

    • This topic was modified 1 year ago by Guinea Pig.
    • This topic was modified 1 year ago by Guinea Pig.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Theme Author Shaped Pixels

    (@shaped-pixels)

    hello,
    this option Customizer > ‘Blog Options’ > ‘Image Post Template Count’ doesn’t apply to normal blog page or archives pages. It simply changes the image post count on the relevant image post template.

    To change the number of posts shown on the blog simply change the WP Settings / Reading “Blog pages show at most” option count

    hope this helps you out

    Thank you for your quick reply and helpful answer.
    It seems i made a mixed-up with ‘blog count’. Sorry for disturbing.

    Kind regards,
    Bert van Giersbergen

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘number of posts per page seems NOT editable in Morphology light version’ is closed to new replies.