Support » Fixing WordPress » Number of Lines in Post Box issue

  • Since updating to the new version of WordPress the size of the Post Box was set back to some default size (guessing 15 lines) with no way to change that default like previously it could be done via Settings => Writing.

    So now when expanding the Post Box manually by stretching it from the bottom right corner to a reasonable size of about 30 lines, something broke because now for no apparent reason the default size of Post Box is 157 lines.

    Quite an inconvenience re-sizing it to normal every time a post draft is manually saved or a new post started. Any solutions?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator kmessinger


    You can drag at the right lower corner to resize it.

    I already said I was doing that. But after doing it now somehow the default box size is 150+ lines not 15. So I have to resize it back to a reasonable size every time I save a draft or start a new post. Not exactly convenient if you have to spend extra minute on setting the screen right on every save or new post.

    Moderator kmessinger


    It should remember if you drag it with the html/text tab.

    I have same problem.
    After updated to 3.5, the writing area changed to about 15 line.
    So I drag the post area in the right bottom conner. change to about 40 line.
    But after that, every post will expand to over 200 line.
    I try to change back to 40 line but it will change back to 200 line after update / save draft

    Yes, I’m seeing the same issue that Johnny & Enterpr1se are seeing: on sites still on WP 3.4.2 you have the familiar “Size of the Post Box” setting, on sites updated to 3.5, it’s gone:

    Note that this setting disappeared from, I’m not certain, maybe 6 months ago… so perhaps it’s an unfeature Automattic created that’s found it’s way into core.

    I assume it’s a bug since I don’t see how disabling this kind of important item would be intentional. Yes of course you can drag the size box, but even if it doesn’t “stick” as it has for some of you, who wants to drag that size box 50 times a day when you can just set what you want?

    I asked Automattic tech support about it back when I first noticed it over there and they replied “oh, you can just use the size box”…

    I’m having the same problem, and it’s a huge annoyance.

    I haven’t counted the number of lines in my editor, but 155- 200 lines sounds about right.

    I do hope that a fix is issued soon for this obvious but.

    We need the option back to set our own default editor size values.

    There’s another thread on this issue marked [Resolved], but it’s clearly NOT resolved:

    HTML tags in the html edit mode of the post do not work. Moving small squares in the “Visual” mode doesn’t work too. Text box shrinks back after you try to make it (text box) wider. Font size is not easy to change HTML code <font size=”2″>…</font> doesn’t work.
    I have suspect it could be conflict of local html code with some settings in some CSS files but which ones?
    I’m afraid it is basic conflict between PHP+CSS versus html and it would be great to get some advice from some of the real WordPress programmer or at least person with some knowledge of the WordPress3.5 structure.

    Moderator kmessinger



    There’s another thread on this issue marked [Resolved], but it’s clearly NOT resolved:

    It was resolved for the original poster.

    As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem – despite any similarity in symptoms – is likely to be completely different.

    I have tried WP 3.5. with three web browsers. Mozilla (17.0.1) and Chrome (the latest version) work with this issue well. But Internet Exporer (with Windows Vista Home) does not: I got also the HUGE text window, both in Visual and Text mode, hardly adjustable. (By the way, with WP 3.4.2. IE had much wider text area in Visual mode, than Mozilla or Chrome; it seemed that even with WP 3.4.2. WYSIWYG did not work well in IE — also the font seen was not actual, /defined by theme Weaver II/. But then it was even good: more text (at page/post) could be seen on wide computer screen.)
    So, I think, something could be bad with WP 3.5. compatibility with Internet Explorer. (I use new, although maybe not the latest IE version).
    My advise (to @inge12): please try some other (modern) browser:-)

    Yes, one of my clients is having the same issue. He has tried it with IE and Firefox. But when I access it from my computer, I don’t have that problem. So it’s not only a browser issue, but obviously something else.

    No, it is a bug. It is not browser specific. See the related discussion here.

    That discussion has a couple of hack suggestions. And it also has some links to the bug ticket and some patches. However at the above link people are saying the patches do not solve the problem.

    My concern is that the bug ticket appears to be closed because they think they resolved the problem.

    I sure hope there is a fix soon. It is really awful!!

    Per @kmessinger, I will open a new thread here on the forum about this. However that seems like the opposite protocol from asking us to search to see if someone else has posted the problem.

    Yep… same problem here! Not happy!

    Well shoot! Might as well wait for next version of WP in hope they are working on fixing this bug…

    There is another thread with a bit more info here

    WARNING – if you do not resize the box it will not get stuck. Small help to all of us finding this thread because our box is already stuck.

    Updating WordPress is usually fairly important because they are always strengthening the security. So you can update; but don’t resize your box.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Number of Lines in Post Box issue’ is closed to new replies.