Support » Plugin: Google Photos Gallery with Shortcodes » “Number of images per page” setting not being applied

  • Resolved davetavres

    (@davetavres)


    On the “Google Photos Pro Settings” page, the “Number of images per page” is not being applied. Instead, the justified gallery code is only displaying 50 images.

    If I change it to 60 or 100, it still only shows 50.

    I’ve purged the cache, tried the page incognito, but it doesn’t change.

    Here’s the shortcode I’m using:
    [cws_gpp_images_by_albumid_gp id='[removed for example]’ thumb_size=250 theme=projig show_details=1 row_height=150]

    What am I doing wrong? 🙂

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nakunakifi

    (@nakunakifi)

    Hi @davetavres

    You are not doing anything wrong.

    Google Photos API returns a maximum of 50 images per result set.

    It’s a limit set by Google, nothing we can fix I’m afraid.

    Ahh… thanks… Perhaps the Google Photos Pro settings page could be updated to show that?

    Or, give users the option of how many API calls to display on a single page?

    Or, when clicking the “NEXT” button to make the next call, don’t reload the whole page?

    AND, add a “BACK” button, to return to the previous 50 images?

    Oh… and, on the Settings page, let users set the “Next” text/value… like “Next page of photos” or “Next [num] images”, etc.

    Thanks

    Plugin Author nakunakifi

    (@nakunakifi)

    @davetavres

    Thank you for your feedback. 🙂

    Of course 🙂

    FYI – I also use “Tela Albums: Google Photo Albums for WordPress” – which IS able to display more than 50 photos on the page, pulling from the same Google Photo Album… see http://www.DeLoreanDirectory.com/deloreans/vin05261

    I hope that helps figure out a solution 🙂

    Plugin Author nakunakifi

    (@nakunakifi)

    Interesting!

    I will be sure to check this out.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“Number of images per page” setting not being applied’ is closed to new replies.