Support » Plugin: Postmark for WordPress » Null object reference?

  • Resolved scott8035

    (@scott8035)


    Hi. I just recently started using Postmark for some of my clients, and there have been a few times when I’ve received this error:

    WordPress version 5.5.1
    Current theme: <custom>
    Current plugin: Postmark (Official) (version 1.13.3)
    PHP version 7.4.9
    Error Details
    =============
    An error of type E_ERROR was caused in line 457 of the file /var/www/staging.edenbooks.org/htdocs/wp-content/plugins/postmark-approved-wordpress-plugin/postmark.php.
    Error message: Uncaught Error: Call to a member function load_settings() on null in /var/www/staging.edenbooks.org/htdocs/wp-content/plugins/postmark-approved-wordpress-plugin/postmark.php:457
    Stack trace:
    #0 /var/www/staging.edenbooks.org/htdocs/wp-includes/class-wp-hook.php(287): pm_upgrade_completed()
    #1 /var/www/staging.edenbooks.org/htdocs/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters()
    #2 /var/www/staging.edenbooks.org/htdocs/wp-includes/plugin.php(478): WP_Hook->do_action()
    #3 /var/www/staging.edenbooks.org/htdocs/wp-admin/includes/class-plugin-upgrader.php(371): do_action()
    #4 /var/www/staging.edenbooks.org/htdocs/wp-admin/includes/ajax-actions.php(4451): Plugin_Upgrader->bulk_upgrade()
    #5 /var/www/staging.edenbooks.org/htdocs/wp-includes/class-wp-hook.php(287): wp_ajax_update_plugin()
    #6 /var/www/staging.edenbooks.org/htdocs/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters()
    #7 /var/www/staging.edenbooks.org/htdocs/wp-includes/plugin.php(478): WP_Hook->do_action()
    #8 /var/www/staging.edenbook

    Seems like there have been a few “gotcha” bugs lately, hope you can fix this soon.

    —scott

Viewing 1 replies (of 1 total)
  • Plugin Author Patrick Graham

    (@prileygraham)

    Hi Scott,

    Thanks for the report! The offending code was in a plugin upgrade completed callback function and is fixed as of the latest version. When upgrading to the latest version 1.13.3, the old plugin upgrade completed callback would have been used, which is why this error still showed up for you. Future upgrades from v1.13.3 to versions above 1.13.3 will not have this error.

    Thanks!

    Patrick

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.