WordPress.org

Support

Support » Plugins and Hacks » [Resolved] "null" for print page

[Resolved] "null" for print page

Viewing 15 replies - 1 through 15 (of 15 total)
  • Sorry, I forgot to mention I want the entire page to be printed. The previous post was when using Firefox. When I tried with IE8, nothing happens.

    Also, the URL for my test page is http://apresinc.com/wordpress/

    Thanks again.

    Plugin Author Baden

    @baden03

    Try assigning the target as ‘body’ like so:

    [print-me title="Print Page" target="body"]

    Let us know if that fixes your wagon!

    No, same result. In IE8 I clicked on the “error on page” at the bottom and this is the msg …

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
    Timestamp: Tue, 20 Nov 2012 17:26:00 UTC

    Message: Invalid argument.
    Line: 32
    Char: 3
    Code: 0
    URI: http://apresinc.com/wordpress/wp-content/plugins/print-o-matic/printomat.js?ver=1.0

    Does this help?

    Plugin Author Baden

    @baden03

    which page did you make the change to? when we checked out http://apresinc.com/wordpress/ the print button still does not have the correct target attribute assigned.

    Also, why is your theme loading an old version of jQuery… from Google?
    https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js?ver=1.6.4
    The current version of jQuery included with WordPress is 1.7.2 yet the theme is loading 1.6.4

    I changed the code on the Home page before and I just added it to the About Us page. This is the code I inserted… [print-me title="Print Form" target="body"]

    Concerning the jQuery question, I created the theme using Artisteer 3.1 and I don’t know how to change it. If this is the problem, could you tell me how to upgrade? Or, I think I can contact them.

    Plugin Author Baden

    @baden03

    check your header.php file for the line:

    <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js?ver=1.6.4'></script>

    If you finde it, remove or comment it out.

    If it’s not there, then check your functions.php file for something like:
    wp_deregister_script('jquery');
    It should be part of a function, and the function should be called using a hook like so:
    add_action("wp_enqueue_scripts", "my_jquery_enqueue", 11);
    comment out the add_action part.

    if this seems a bit uncomfortable or you get stuck, we would be happy to log in and get everything working for you.

    Thanks for finding and fixing the conflict with the The The Image Slider plugin!

    Oooops! The fix only worked in Firefox not IE8. Here’s the page error I received…

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
    Timestamp: Wed, 28 Nov 2012 21:26:13 UTC

    Message: Invalid argument.
    Line: 32
    Char: 3
    Code: 0
    URI: http://apresinc.com/wordpress/wp-content/plugins/print-o-matic/printomat.js?ver=1.0

    Plugin Author Baden

    @baden03

    The quality of IE never seises to amaze. There seems to be an issue with using spaces and dashes in a new window. Yay for IE. We have fixed it on your install, please test it and get back to us. If it fixes the issue, we will issue an official update.

    Thanks, and sorry for anyone out there that is forced to use IE against there own free will.

    It works 🙂 I despise Microsoft and IE, but unfortunately the people that use the site also use IE.

    Thanks for ALL your help! Look forward to the update so I can fix another site I work on.

    Plugin Author Baden

    @baden03

    version 1.0.1 has just been released, that addresses this issue. yay.

    Hi all,

    I have the same problem, except that the null comes out in chrome, IE and firefox:D

    The null appears on the far top left of the page and in firefox, the printing page comes up with the previewed page (which also has a null in it).

    Help:(

    Thanks

    Plugin Author Baden

    @baden03

    Please post a link to your page, and the exact shortcode you are using.

    check out the homepage of my website (ignore the first printer icon you see and go to the first one below “Mr. Ian Harrison , BA Cert Ed”

    http://tbs-madinaty.com/test/
    thanks

    Plugin Author Baden

    @baden03

    Nothing on the page, only:
    Windows NT WEB713 6.1 build 7601 (Windows Server 2008 R2 Standard Edition Service Pack 1) i586

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] "null" for print page’ is closed to new replies.