Support » Plugin: NewStatPress » nsp_api_overview.php in v1.2.1 – and External API w/Dashboard Widget

  • There are extra whitespace characters after the closing PHP tag which causes the fun, following message:

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/newstatpress/includes/api/nsp_api_overview.php:101)

    Simply removing the closing PHP tag would solve the problem in case whitespace is ever introduced again.

    It also seems that with the just released 1.2.1 version that requires the External API to be activated — if the dashboard widget is selected to be activated by the plugin from previous installs (which requires the External API be enabled), then the External API should probably be enabled by default during the upgrade process, otherwise the widget no longer works and the only way I discovered why was reading the changelog and the newly provided PDF in the docs folder. I’m thinking other users may not be as capable as I am to find that. 🙂

    https://wordpress.org/plugins/newstatpress/

Viewing 1 replies (of 1 total)
  • Plugin Author cHab

    (@lechab)

    Hi,
    Thank you for your message. Indeed the warning about header is a classic issue but we didn’t see it: will be fix in next version.

    Regarding documentation and the activation of External API (need before 1.2.1) it is already scheduled to improve that soon.

    Thank again, feedback is important to improve the plugin.
    cHab

Viewing 1 replies (of 1 total)
  • The topic ‘nsp_api_overview.php in v1.2.1 – and External API w/Dashboard Widget’ is closed to new replies.