Support » Plugin: NS Cloner - Site Copier » NS Cloner & Webpage Redirect Loop

  • Resolved wdnatx


    This has happened several times: I clone a site with NS Cloner, then go visit the site and get the following errors:

    Chrome: “This webpage has a redirect loop.”

    Safari: “Safari can’t open the page. Too many redirects when trying to open

    Has anyone else had this problem? I really can’t figure out how to reproduce it. It’s not (parent) site dependent. It often happens when I create a site via NS Cloner, but occasionally the problem doesn’t occur. I’ve never had the redirect problem (that I know of) on a network site that was created manually (not an NS Cloner site). I have a static IP on a shared GoDaddy hosting plan.

    I love the simplicity of NS Cloner but, needless to say, these redirect loops are giving me a lot of gray hair.

    Thanks in advance for any help!


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Never Settle


    That is really strange. We’ve never seen redirect loops after cloning. Have you double-checked that your .htaccess file is the standard version for a subdomain install?

    I’m trying to think what might be the cause. Are you also running any domain mapping plugins and are those domain mapping plugins active / configured on the source site? That could maybe cause that scenario.

    If you want to post a couple example sites with the redirect loop and the correlating logs from when they were cloned (under wp-content/plugins/ns-cloner-site-copier/logs) and send those through this form:

    We’d be happy to take a close look. This sounds like something that should be sortable.


    I too started receiving a redirect loop error when attempting to use NS Cloner. This started recently, with the latest version. The parent site does not use any domain mapping.

    Plugin Author Never Settle


    Do you mean the latest version of the Cloner? or the latest version of WP? And was the Cloner previously working for you no problem?

    Can you provide example URLs where the redirect loop is happening?

    Are you in a subdomain install or subdirectory install? This issue seems more common in subdirectory installs.

    Please check your home and site URLs under Network Admin > Sites > All Sites > Edit site link > Settings tab.

    Latest version of WordPress, 3.9. Cloner has worked succesfully 40+ times in the past. I’m on a subdomain install.

    Any progress here? Redirect loop is frustrating…

    Plugin Author Never Settle


    Have you checked your home and site URLs under Network Admin > Sites > All Sites > Edit site link > Settings tab and compared them to what they should be?

    There are no other known cases of this, and we can’t reproduce the issue, so it seems like it might be isolated to your environment. Maybe something else changed around the same time? Any other potential factors?

    You can also send us your logs from /wp-content/plugins/ns-cloner-site-copier here:
    and we’ll analyze them for clues.


    I am having the same issue. I have just tried cloning my a site on a multisite install.

    The subdomain I generated is called

    Chrome error message: This web page has a redirect loop

    Firefox error message: Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    Can you please advise if there has been any further update in regards to this issue?

    Plugin Author Never Settle


    This issue should not occur on properly configured multisite installs when following the guidance on usage with domain mapping plugins (if applicable).

    Potential causes:

    • incorrect .htaccess rules
    • cloning a site with active and configured domain mapping rules (you can use domain mapping, but the template site should not have active domain mapping rules because those will be copied to the clone identically which can cause a issues)
    • incorrect settings at the hosting level with subdomains, no wildcard DNS, domain forwarding, etc.
    • a change in the root domain of the WP install

    A quick test you can do is to create a subsite manually, the normal way through the WP Network Admin, and see what it does. Does it work? What
    are the differences? Compare Home and Site URL of both the clone site and the manually created site.

    There could be an issue with the 4 section host name, but it should work. In most cases editing the Home and Site URL under Network Admin > Sites > All Sites > Edit site link > Settings tab can be a good sanity check and work-around. But if there’s an issue in some rare cases with the Cloner the only way we can patch it is to get a concrete / reproducible example of the issue. So far we didn’t receive examples or logs from the other reports on this, and we haven’t been able to get the issue to occur ourselves.

    You can send us your logs (/wp-content/plugins/ns-cloner-site-copier/logs) here:


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘NS Cloner & Webpage Redirect Loop’ is closed to new replies.