Support » Plugin: LiteSpeed Cache » Nonce failures

  • Resolved Candlelite

    (@candlelite)


    I have shared hosting with Krystal (https://krystal.uk/) and use your plugin on all my hosted sites. Some are made with Template Toster (https://templatetoaster.com/) and some are made with Divi (https://www.elegantthemes.com/). The page I have asked for help with is an “example” on a TemplateToaster site – other pages with forms are also failing intermittently. The form plugin on both types of sites is Forminator (https://wordpress.org/plugins/forminator/). Your plugin config is default except for the pages that have forms which have been excluded from cache. However on Divi and Template Toster sites I am getting the error reported from customers: Invalid nonce. Please refresh your browser. This is an intermittent problem but is happening frequently enough to cause problems with customers and site owners. From what I have read on various sites this is a caching problem (lots of references to WP Super Cache) and perhaps config in the htaccess file. I have not yet tried deactivating your plugin or changing the form plugin but before I start on these options I was wondering if you had any advice?
    Regards

    • This topic was modified 1 year, 2 months ago by Candlelite.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Did you enable ESI ?

    Best regards,

    Thread Starter Candlelite

    (@candlelite)

    No this is a default install. Is it recommended that ESI is enabled?

    Plugin Support qtwrk

    (@qtwrk)

    Yes, ESI is meant to address the nonce expiration issue.

    Thread Starter Candlelite

    (@candlelite)

    Thanks I have set it on and will see if this fixes the problem.
    Would you also recommend that Memcached and Redis be enabled on the server?

    Plugin Support qtwrk

    (@qtwrk)

    if you can enable them , then yes , and only one of them is enough

    Thread Starter Candlelite

    (@candlelite)

    I can enable both – if I only enable Redis then in Cache Settings – Object – Method I need to set this to Redis and if I only enable Memcached then Method is set to Memcached? Sorry to be pedantic.

    Plugin Support qtwrk

    (@qtwrk)

    yes, that’s correct

    please do remember , besides PHP extension , you will also need to install the Redis or Memcached server process as well

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Nonce failures’ is closed to new replies.