Support » Plugin: WooCommerce Shipping & Tax » Notifications showing in Vendor Dashboard

  • Resolved kkitran

    (@kkitran)


    Hello!

    Every time I get a notification for an error, or just any notification it shows to all the vendors as well. How to disable this?

    “An error occurred in WooCommerce Services. Details are logged here.”

    This error is shown in every dashboard… Can it just show only to the admin? And even if I disable woocommerce service then there is a notification to all the vendors to install the plugin. These notifications should be just for the actual admin.

    Okay thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Jesse Pearson (a11n)

    (@jessepearson)

    Automattic Happiness Engineer

    @kkitran If the plugin you are using for vendors places the vendors in a different role, you can add a function to your theme to unhook the action that renders the notices. This is the code that should unhook the action:

    
    remove_action( 'admin_notices', array( WC_Connect_Error_Notice::instance(), 'render_notice' ) );
    

    If you just add this straight, it will remove notices for all users. It will need to be wrapped in a function to determine the user’s role for it to work correctly.

    • This reply was modified 4 years, 2 months ago by Jesse Pearson (a11n). Reason: Changed add_action to remove_action
    Thread Starter kkitran

    (@kkitran)

    Thank you for a solution! I don’t know what you mean by wrapping it in a function. I’m not well acquainted with coding.

    Plugin Support Jesse Pearson (a11n)

    (@jessepearson)

    Automattic Happiness Engineer

    That’s a little beyond what we are able to support here since it is something that would need to be specifically coded for your site.

    I did a Google search and it appears there are several ways to hide admin notices for all users but admins.

    Thread Starter kkitran

    (@kkitran)

    Good suggestion! Thank you

    There are some errors like “Error retrieving the tax rates. Received (400): {“error”:”Bad Request”,”detail”:”to_zip 37932 is not used within to_state FL”,”status”:400} (WCS Tax)” I noticed on my profile that the state was wrong and I changed it to the appropriate state. However, this error doesn’t go away and same with other errors.

    So, great I can hide the Woocommerse Service notification from other users but I still get it even when the issues were fixed.

    • This reply was modified 4 years, 2 months ago by kkitran.
    Plugin Support Jesse Pearson (a11n)

    (@jessepearson)

    Automattic Happiness Engineer

    @kkitran That error you listed will happen if someone enters a zip code that doesn’t match a state when they are checking out. Are you getting it consistently?

    Thread Starter kkitran

    (@kkitran)

    Yes, it’s strange

    Plugin Support melinda a11n

    (@melindahelt)

    Automattic Happiness Engineer

    This error means that the state and zipcode entered at checkout do not match, not that your from zip code isn’t correct.

    Have you cleared your cache after you fixed your zip code and tested again on checkout using a valid zipcode for a state.

    Plugin Support Julia Amosova

    (@jamosova)

    Automattic Happiness Engineer

    Hi @kkitran, please let us know if you’ve tried the steps recommended by @melindahelt above? Let us know if the issue is fixed on your end and if we can close this thread. Thanks!

    Plugin Support Julia Amosova

    (@jamosova)

    Automattic Happiness Engineer

    Hi @kkitran, looks like you are all set for now so I am going to mark this thread as Resolved. Feel free to connect with us again should you have any additional questions!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Notifications showing in Vendor Dashboard’ is closed to new replies.