Support » Plugin: Broken Link Checker » Notifications get high spam score

  • Resolved voodoochill

    (@voodoochill)


    This is a great plugin, but I find that the email notifications are getting a high spam score with cpanel spam assassin

    Is there anything cna be done about this? thanks.

      0.8 BAYES_50               BODY: Bayes spam probability is 40 to 60%
                                 [score: 0.4999]
      0.8 KAM_COUK               Scoring .co.uk emails higher due to poor registry
                                 security.
      0.0 URIBL_BLOCKED          ADMINISTRATOR NOTICE: The query to URIBL was
                                 blocked.  See
                                 http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block
                                  for more information.
                                 [URIs: xxxxxxxxxxxxxxx]
     -0.0 RCVD_IN_MSPIKE_H2      RBL: Average reputation (+2)
                                 [104.245.209.196 listed in wl.mailspike.net]
     -0.0 SPF_PASS               SPF: sender matches SPF record
      0.1 MIME_HTML_ONLY         BODY: Message only has text/html MIME parts
      0.0 HTML_MESSAGE           BODY: HTML included in message
      0.1 HTTPS_HTTP_MISMATCH    BODY: No description available.
      1.4 HTML_IMAGE_ONLY_28     BODY: HTML: images with 2400-2800 bytes of
                                 words
      1.1 KAM_REALLYHUGEIMGSRC   RAW: Spam with image tags with ridiculously
                                  huge http urls
      0.1 DKIM_SIGNED            Message has a DKIM or DK signature, not necessarily
                                 valid
     -0.1 DKIM_VALID_AU          Message has a valid DKIM or DK signature from
                                 author's domain
     -0.1 DKIM_VALID_EF          Message has a valid DKIM or DK signature from
                                 envelope-from domain
     -0.1 DKIM_VALID             Message has at least one valid DKIM or DK signature
      0.4 HTML_MIME_NO_HTML_TAG  HTML-only message, but there is no HTML
                                 tag
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @voodoochill,

    It seems that the report there is mostly because of the number of URLs and their length, unfortunately they can’t really be excluded from the email as they are part of the report itself.

    Do you get the same report about the emails sent when there are less URLs included inside of it?

    Cheers,
    Predrag

    Thread Starter voodoochill

    (@voodoochill)

    Thanks for replaying. No I think it is only specific reports. In this case there were only three URLs – all appear to be the same though.

    Oddly they weren’t actually broken, but I would put that down to incorrect status header at Amazon?

    This is one of them and yes, it’s very long

    https://www.amazon.com/Private-Girl-Spicy-Music-Betty-Page/dp/B00005Y2E5?SubscriptionId=AKIAJNW3SUXQYO4KKQIQ&tag=cdun09-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B00005Y2E5

    I have managed to work out a way to shorten it so let’s see if that solves the issue. I’ll keep an eye on it

    Is there a way to force the email notification so I can test it?

    Thanks

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @voodoochill

    It’s really hard to say what spam filter will exactly do with a message that contains any links – but usually if there’s either a lot of them or at least some of them are a bit “unusual” or “complex” (like that example Amazon link) that triggers some “red flags” in spam filters.

    For whatever it sounds like, it’s actually good to simply keep marking these mails as non-spam manually (if it’s possible) as some spam filters will keep “learning” this way. Or just white-list them if doable.

    Is there a way to force the email notification so I can test it?

    Try this:

    – put the link on some test page/post where it wasn’t used yet
    – on “Settings -> Link Checker” page in “General” tab make sure that “Send me e-mail notification about newly detected broken links” option is enabled
    – then switch to “Advanced” tab and click “Re-check all pages” button at the bottom

    This should force “re-check” and the link should be detected, triggering notification if it’s detected as broken.

    Best regards,
    Adam

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @voodoochill

    I hope you are doing well!

    We haven’t heard back from you for a while now so we’ve marked this ticket as resolved. If you do have any followup questions or require further assistance feel free to reopen it and let us know here.

    Kind regards,
    Nastia

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Notifications get high spam score’ is closed to new replies.