Support » Plugin: Yoast SEO » Notification will not disappear

  • Resolved 2Flow2


    Hi there! In my WordPress dashboard, along the top rail, I have a notification from Yoast SEO that displays a persistant red number indicating there is a new notification to view.
    (See image:

    Going to the Yoast SEO Dashboard shows that I have a notification informing me that there is a plugin I can download to enhance my WooCommerce and YoastSEO integration. I have acknowledged this notification and no longer wish to view it or be notified of it, but when I click the small icon next to the notification (an eye symbol with a line through it), the notification becomes faded, but the notification indicator on the upper bar does not disappear, and upon any page reload the notification has been un-faded and continues to show. (See image:

    I assume this is a bug. How do I get the notification to stay hidden after I click the icon to hide it? I do not wish to install an additional WooCommerce plugin.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support devnihil


    We’re sorry to hear you are experiencing this issue on your site.

    Can you please confirm you are using the most recent release of Yoast SEO version 16.9? You can learn more about updating here:

    Also, can you confirm you are using WordPress 5.8? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more:

    If you update to the most current version of WordPress and Yoast SEO, does this resolve the issue?

    If you have confirmed both WordPress, Yoast SEO, and all of your site’s other plugins and themes are up to date and the problem is still occurring, we would next recommend to try clearing the site’s cache. If you clear your cache (server, plugin/theme, browser, or CDN such as Cloudflare) does this resolve the issue? If you are not sure how to clear your server cache you should speak with your host provider. We have information on how to clear your browser cache at the following link:

    Thread Starter 2Flow2


    Hi there, thanks for the reply.

    I can confirm that my Yoast SEO version is 16.9, and my WordPress version is 5.8. Both of those were already the case.

    I have ensured all of my other plugins are updated.

    At your reeuqest I have cleared my site’s Cloudflare cache, and have cleared the “SuperCacher” feature provided by my host, SiteGround. There is no other caching features present on my website that I know of.

    I can provide screenshots of any of these actions if need be.

    After all of this, I accessed the website dashboard from a new browser on which I have never visited the site before. The problem still persists, and the notification still does not go away. What should I do next? Is there something that needs to be updated on your end?

    Plugin Support Md Mazedul Islam Khan


    Thanks for your clarification @emite. We are afraid to say that we were unable to reproduce the issue on our end. We can confirm that whenever you removed the relevant notification on a fresh WordPress website on our end, the relevant notifications counter hit 0 as expected.

    That said, can you please try disabling and re-enabling the Yoast SEO plugin temporarily to see whether this resolves the issue for you?

    If the issue persists, we recommend you please install the Yoast Test Helper plugin on your website and perform the following steps to reset the notifications:

    • Go to Tools → Yoast Test;
    • Click the Reset Notifications under the Yoast SEO sections;

    Let us know whether the issue persists after following the above steps.

    Thread Starter 2Flow2


    Hi there, thank you very much for the reply!

    I disabled the Yoast SEO plugin, as well as the Yoast Duplicate Post plugin, and then re-enabled them. Upon re-enabling the plugins, there are now 2 notifications being displayed by Yoast in the upper bar instead of 1.

    One of the notifications is the same notification that appeared before, reading “Yoast SEO and WooCommerce can work together a lot better by adding a helper plugin. Please install Yoast WooCommerce SEO to make your life better. More information.” This notification is acting exactly the same as before, and clicking the icon to hide it does nothing but grey out the notifictions area without removing the actual notification itself.

    The new, second notification that has appeared displays more odd behavior. The notification reads “You can speed up your site and get insight into your internal linking structure by letting us perform a few optimizations to the way SEO data is stored.

    We estimate this will take a couple of minutes.
    Upon clicking the icon to hide this notification, both notifications do successfully clear. They disappear and it says I have 0 notifications, with “1 hidden notification” (the message to speed up my site with storage optimizations). However, whenever a new page is navigated to or when the current page is reloaded, one notification will come back and it will display that I have “1 notification” (the SEO/Woocommerce notification). Then, upon navigating to a second new page or reloading the current page a second time, the second notification will return and it will display that I have “2 notifications”. At that point, I am back to where I started, and the process can repeat itself.

    I have taken a video of this in action because I believe it easier to see done than trying to comprehend it over text:

    I also tried installing the Yoast Test Helper and following the steps you described. Unforunately, clicking the “Reset Notifications” button did nothing (other than bring up a green banner that said “Yoast SEO feature Notifications has been reset.” but none of the notifications actually disappear).

    Let me know what I should do next. Thank you for helping me work to resolve this.

    Plugin Support Michael Tiña


    Hi @emite

    We tried testing these notifications on one of our test sites, and they stayed hidden and didn’t pop up to signify any sort of notification even after refreshing and reloading the page. Please find the attached recording –

    Since we’re unable to reproduce the issue on our end, and you’ve mentioned that you’ve already tried resetting notifications with the Yoast Test Helper plugin, and you’ve cleared the cache, would it be possible for you to try and do a conflict check?

    Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    If you do not feel comfortable to do this yourself or if this does not solve your issue, our Yoast SEO Premium plugin comes with one year of (technical) support.

    Plugin Support Michael Tiña



    This thread has been marked as resolved due to lack of activity by original poster.

    If you are not the original poster but have a similar issue, please open a new request.

    Thread Starter 2Flow2


    It looks like it is some sort of conflict with another plugin, because when I disable all other plugins, the notifications stay hidden. They come back when I re-enable the rest of my plugins, however.

    I’m not sure which one might be causing this. I suppose I would have to individually turn each one of them on one by one until I see the issue happen again.

    • This reply was modified 1 year, 6 months ago by 2Flow2.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Notification will not disappear’ is closed to new replies.