• Resolved patbell101

    (@patbell101)


    When I activate an image the uploader gets an notification but the url they are supposed to link to their image is invalid. They get this message

    Redirect Notice

     The page you were on is trying to send you to an invalid URL (http://xn--$url$-nw3bf).

     If you do not want to visit that page, you can return to the previous page.

    I have tested to myself and tried in different browsers. Have I mnisconfigured something?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Wasiliy Strecker / ContestGallery developer

    (@contest-gallery)

    Please check it the $url$ paramter was inserted clean, via clicking the text type of tynmce editor:

    https://capture.dropbox.com/C5cdHFdjE9K7nxya

    Also if you are using a gallery created bevor version 21, then you have to set URL page link where the shortcode is inserted, additionally:

    https://capture.dropbox.com/uGmqZK6k6nNNGO1y

    Plugin Author Wasiliy Strecker / ContestGallery developer

    (@contest-gallery)

    Marked as resolved so far.

    Thread Starter patbell101

    (@patbell101)

    This is what is inserted by default in a new gallery

    <p>Dear Sir or Madam<br />Your file was published. <br /><br /><br /></p>
    <p><a href="”$url$”">View your entry</a></p>

    I have tried href=$url$ but it doesnt substitute the $url$ and results in The page you were on is trying to send you to an invalid URL (http://$url$).

    I guess I am not changing it correctly to give me a clickable link

    • This reply was modified 1 year ago by patbell101.
    Plugin Author Wasiliy Strecker / ContestGallery developer

    (@contest-gallery)

    It should be without ”

    <p>Dear Sir or Madam<br />Your file was published. <br /><br /><br /></p> <p><a href="$url$">View your entry</a></p>

    and not code like “%24/” or so

    like here:
    https://capture.dropbox.com/C5cdHFdjE9K7nxya

    <<< try without a tag wrap first

    Thread Starter patbell101

    (@patbell101)

    OK. I tried a @bare? $url$ and $info$ and both just came through as input. But in Admin notification $info$ was substituted correctly. I tried $url$ there too and that didn’t work.

    afaics $url$ is not getting substituted anywhere. And File notification email isn’t doing any substitution at all.

    Is it because I am on v18.0.1.2 Pro?

    Thread Starter patbell101

    (@patbell101)

    I did also try

    <p>Dear Sir or Madam<br />Your file was published. <br /><br /><br /></p> <p><a href=$url$>View your entry</a></p>

    Which gave me this

    The page you were on is trying to send you to an invalid URL (http://$url$).

    If you do not want to visit that page, you can return to the previous page.

    Where does it get the url from?

    Plugin Author Wasiliy Strecker / ContestGallery developer

    (@contest-gallery)

    If you use “v18.0.1.2” then you have also to fill out the URL field:

    https://capture.dropbox.com/uGmqZK6k6nNNGO1y

    Please try out to put simply only the $url$ parameter and nothing else.
    If then does not work then please update to the latest version, because if there is really some kind of error in older version I do not correct older versions anymore, and send me temporary backend access to support-pro@contest-gallery.com.

    In general if you using PRO version, then please contact support-pro@contest-gallery.com , because of the WordPress.org rules, that premium versions should not be discussed in this forum.

    Thread Starter patbell101

    (@patbell101)

    I see, sorted now. ANd I will use the Pro email address in future.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Notification emails sends invalid URL’ is closed to new replies.