Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Notification emails don’t send

  • Resolved steckscout

    (@steckscout)


    Hello! I’ve noticed that sometimes the emails that should be generated by this plugin just inexplicably do not send. The response data is captured, the emails are regularly sent, but not always. What might be causing this and how can I fix it? Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I just want to note we have the same issue.

    Plugin Support Prathamesh – WPMU DEV Support

    (@wpmudev-support7)

    Hello @jmeyer2485 @steckscout,

    Overall the issue on emails not being sent look like to be on the server-side. Of course, there can be other issues like process time outs to something like that but that is really rare. Could you let me know if your forms are really big or they are medium-sized firms? Does your form consist of images that are too big in size? Are you using the wp_mail way to send the emails or you are using SMTP?

    Another way to understand why this could be happening is to keep a track of the emails being sent from WordPress. To do that, you can install the following plugins: https://wordpress.org/plugins/email-log/

    This way you can log and view all the emails that were sent using that and also figure out what happened when the emails were not delivered. If you see the email being sent in the log, that would not be an issue with the plugin and you would need to check the same with your hosts but if you do not see a log, then there is certainly a need to check this deeply on our end. Do let me know how that works on your end.

    Thank you,
    Prathamesh Palve

    Thread Starter steckscout

    (@steckscout)

    I’ve installed the plugin you suggested and I can see them in the log when they don’t send. The issues usually occur with yahoo email accounts, though this isn’t a universal rule. Any idea what might be causing this? @wpmudev-support7

    • This reply was modified 6 months, 3 weeks ago by steckscout.
    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @steckscout

    If those mails are listed in the log as sent then this means that on “Forminator/WordPres level” it’s fine and the issue is somewhere else.

    If it was about all the e-mails, I’d say that it’s almost for sure either some restriction or some configuration issue on the server but since some of the e-mails are delivered successfully it’s a bit more difficult to poinpoint.

    Firs thing to check would be to make sure that those messages are not moved to some spam/junk folder in recipient’s inbox. This isn’t that uncommon and easy to overlook so please make sure about it.

    If you can confirm that they are not then check your sender e-mail inbox to see if you can find any “bounce” messages or similar “error” responses. IF that also doesn’t show anything, please also ask you host if they could check logs on their end (if you are not using SMTP for sending mails) to see if they can find any clues in logs.

    This is because

    – there are different spam filters using various rules (more or less strict) at multiple stages of e-mail “route” (surely at recipient’s end but sometimes also at sender’s server and “somewhere on the way)
    – there might be some restrictions server-side
    – and, unfortunately, in some cases both of the above may be “silent” leaving only traces in logs

    so it’s worth checking.

    If none of that helps or, at least, gives some clues on what might be happening then, if you haven’t tried that yet, please try switching your site to use SMTP for e-mails with a free plugin such as for example:

    https://wordpress.org/plugins/branda-white-labeling/

    or

    https://wordpress.org/plugins/post-smtp/

    or similar.

    Best regards,
    Adam

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @steckscout ,

    We haven’t heard from you for a while now, so we assume that using SMTP plugin worked for you.
    Please feel free to re-open this ticket if needed.

    kind regards,
    Kasia

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Notification emails don’t send’ is closed to new replies.