Support » Plugin: Mail Bank - #1 Mail SMTP Plugin for WordPress » Notification e-mails going to SPAM

  • Resolved CraigGDodge

    (@craiggdodge)


    I was using Postman-SMTP until the security issue, and changed to MailBank. Since then, about half the time, notification e-mails end up in my SPAM folder. This didn’t happen with Postman.

    We use Gmail POP to fetch from our e-mail host.

    Thoughts?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Varun Sharma

    (@contact-banker)

    Hi,

    That’s strange.

    Are you using the Google API for authentication to connect to the smtp in Mail Bank?

    Please let us know!

    Thanks

    Thread Starter CraigGDodge

    (@craiggdodge)

    No. We have linked Mail Bank to our e-mail host (Dreamhost) , and then Gmail POP to fetch from Dreamhost.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Why not just directly connect to Gmail?

    Thread Starter CraigGDodge

    (@craiggdodge)

    Because we’re a business, and we want to use our business e-mail address.

    Additionally, not all of our staff uses Gmail as their e-mail client. Some use Outlook.

    Bottom line is that with Postman, the e-mails were going to my Inbox 100% of the time and with WP SMTP they occasionally go to SPAM. As far as I can tell, the settings are identical: Notifications being sent from sales@pharecircus.org , replyto is the customer’s e-mail address. Auto-replies to the customer are from sales@pharecircus.org .

    If you don’t see that as a problem, then we’ll just deal with it.

    Plugin Author Varun Sharma

    (@contact-banker)

    Hi,

    Please make sure the From Email Address, Email Address and the Username used for authentication of SMTP Server in Mail Bank Wizard Setup should be same!

    Mail Bank has nothing to do with emails arriving in Spam Folders though as it just forwards the email with the parameters you provided!

    We recommend reading this post as it might help you fixing the issue https://www.thenewsletterplugin.com/emails-end-spam-folder

    Hope that helps!

    • This reply was modified 4 years, 1 month ago by Varun Sharma.
    Plugin Author Varun Sharma

    (@contact-banker)

    To avoid being flagged as spam, you need to prove your email isn’t forged. On a custom domain, its up to you to set that up:

    • Ensure you are using the correct SMTP server with authentication – the correct SMTP server is the one defined by your email service’s SPF record.
    • If you use a custom domain name for email, add an SPF record to your DNS zone file. The SPF is specific to your email provider, for example Google
    • If you use a custom domain name for email, add a DKIM record to your DNS zone file and upload your Domain Key (a digital signature) to, for example Google
    • This reply was modified 4 years, 1 month ago by Varun Sharma.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Notification e-mails going to SPAM’ is closed to new replies.