Support » Plugin: iThemes Security (formerly Better WP Security) » Notification Center configuration not working

  • Hi all,

    I am receiving following error under Notification Center setting.

    Error while sending notification: Invalid address: (setFrom) wordpress@. View All.

    How to get this to work please?

    Regards

Viewing 9 replies - 1 through 9 (of 9 total)
  • Looks like the site doesn’t have a “Site Address (URL)” in the WordPress General Settings page (Settings/General). So seems like a site specific issue.

    Just out of curiosity, what happens when you click on the “View All” link ?

    To prevent any confusion, I’m not iThemes.

    View All brings me to the Logs page. That is it.

    Ok, and there is actually log content displayed ?

    The code below shows how the default From address is created (wp_send() function in wp-includes/pluggable.php):

    $sitename = wp_parse_url( network_home_url(), PHP_URL_HOST );
    if ( 'www.' === substr( $sitename, 0, 4 ) ) {
    	$sitename = substr( $sitename, 4 );
    }
    
    $from_email = 'wordpress@' . $sitename;

    Is it a multisite WordPress env ?

    Make sure the From Email setting in the Notification Center module is empty (no spaces).

    One other thing, what WordPress version is being used ? (PHPMailer was updated in the latest (5.5.x) WordPress release).

    • This reply was modified 1 month, 2 weeks ago by nlpro.

    It’s not a multi-site.

    What WordPress version is being used ? (PHPMailer was updated in the latest (5.5.x) WordPress release).

    Using the latest WordPress version and website is up to date.

    • This reply was modified 1 month, 2 weeks ago by wpreceiver.

    Ok, but this wasn’t a clean 5.5.x install ? You upgraded from an older WordPress release to 5.5.x recently ?

    It could be the error was generated in a previous WordPress release. These type of errors get stored in the database and keep showing up untill you dismiss them. If I’m correct you can click on the X sign to dismiss the error.

    Are there currently any emails being send from this WordPress env ? (Either from the plugin or from WordPress).

    This is not a purely installed. But website is upto date. This works so far.

    Ok. So the bottom line is that the error that is being displayed seems to be a relic from the past. As the error is stored in the database and it has not (yet) been dismissed it just keeps showing up.

    Since WordPress, PHPMailer and probably the iTSec plugin have all been updated recently it’s very well possible the root cause is no longer there for the error to reoccur.

    Clicking on the View All link takes you to the plugin logs page and if content is displayed you may still be able to pinpoint the exact date this particular error occurred (as well as other relevant info logged). Do note log data is kept 60 days by default. So if the error was the result of a problem more than 60 days ago, there is a good chance the log entry has already been removed (that is if the purge log data cron event is properly functioning).

    For now (if not already) simply dismiss the error (which will remove the error from the database), and then keep monitoring the (email) situation.

    Since emails seem to be send successfully at this moment, I don’t expect this particular error to reoccur 😉

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.