Support » Plugin: Better Notifications for WP » Notification being sent to all members

  • Resolved dimitriosvasileiou

    (@dimitriosvasileiou)


    The problem must have been created in the latest update of the 25th of May as I did not have a problem before.

    A few minutes ago one of our posts was published. Although so far a notification would be sent to the post’s author, this time a notification was sent to ALL authors registered on the website.

    I will repeat that this never happened before.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author bnfw

    (@voltronik)

    Hi @dimitriosvasileiou,
    Thanks for your message.

    So, to clarify:

    1. You have a post published notification.
    2. It is set to Send to the Author only
    3. It is sending to all users in the Author user role on the site.

    Is that correct?

    Correct. See the screenshot I have uploaded to the link below (sorry for link but I cannot upload it here).

    https://landscapephotographymagazine.com/sample/1111.jpg

    Plugin Author bnfw

    (@voltronik)

    Hi @dimitriosvasileiou,
    Thanks for the screenshot.

    The reason for this is that you’re sending it to both the post author AND the Author user role.
    If you remove the user role from the notification, this should work as expected.

    The update included a feature where you can include both which is probably what you’re seeing although, I think your particular issue would have only occurred if you had added a user role into that box, saved the notification, then ticked the ‘Send this notification to the Author only’ checkbox afterwards and then saved it again.

    Hope this helps.

    “If you remove the user role from the notification, this should work as expected”

    You cannot do that. I tried to do it and got the message: You must choose at least one User or User Role to send the notification to before you can save.

    Plugin Author bnfw

    (@voltronik)

    Hi @dimitriosvasileiou,
    Hmmm, that’s odd. I haven’t experienced that in testing.

    Are you able to re-create the notification as new without the Author user role added but with the ‘Send to the Author’ checkbox ticked?

    The same warning when I try to create a new notification (see link).

    https://landscapephotographymagazine.com/sample/1112.jpg

    Any more ideas?

    Plugin Author bnfw

    (@voltronik)

    Hi @dimitriosvasileiou,
    This didn’t show up in my initial testing however, i’ve now been able to re-create this and can confirm it’s a bug. I’ve added it to my list of things to look at in June and should be able to issue a release this month.

    I’ll leave this thread open until the release is made.

    Excellent. Thank you for taking the time.

    Meanwhile, and this is for all others who have the problem, I created a membership level with 0 members and added this in the box – it allowed me to save the changes and works well.

    Plugin Author bnfw

    (@voltronik)

    Hi @dimitriosvasileiou,
    No probs.

    Great idea for a temporary work-around solution until i’ve issued a fix too!

    Plugin Author bnfw

    (@voltronik)

    Just to say that this issue is resolved in the next version of BNFW, due for release soon.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Notification being sent to all members’ is closed to new replies.