Support » Plugin: Instant Indexing for Google » notif error functions.php on line 5225

  • What is this error? How do i resolve this ?

    my wordpress use version 5.5.1
    php version 7.4

    notif error in dashboard wordpress:
    `Notice: add_submenu_page was called incorrectly. The seventh parameter passed to add_submenu_page () must be an integer representing the menu position. Please see Debugging in WordPress for more information. (This message was added in version 5.3.0.) In /home/soft/public_html/wp-includes/functions.php on line 5225′

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Did you try disabling the Instant Indexing for Google and see if the issue resolved?

    Looking forward to helping you.

    KoolPal

    (@koolpal)

    @rankmath @kodok123

    Landed here to report the same issue:
    WooCommerce version: 4.7.1
    WordPress version: 5.5.3
    Instant Indexing by Rank Math – 1.0.0

    [30-Nov-2020 08:46:17 UTC] PHP Notice: add_submenu_page was called <strong>incorrectly</strong>. The seventh parameter passed to <code>add_submenu_page()</code> should be an integer representing menu position. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.3.0.) in [path]\wp-includes\functions.php on line 5229

    This notice is definitely linked to this plugin!

    Please review and guide / fix.

    Thanks

    error is in file class-instant-indexing.php , line 379
    but i can’t fix it 🙁

    stacktrace :
    require(‘wp-admin/menu.php’), require_once(‘wp-admin/includes/menu.php’), do_action(‘admin_menu’), WP_Hook->do_action, WP_Hook->apply_filters, RM_GIAPI->admin_menu, add_submenu_page, _doing_it_wrong,

    It says it in the error message, the 7th parameter should be an integer.

    When looking at the code, it has a string with 'none' as the 7th, so the fix is to remove that (invalid) parameter entirely.
    Not sure why it’s there, maybe some kind of backwards compatibility that is breaking newer versions of WP?!

    In class-instant-indexing.php:379:
    ... , 'none', 76 ); should be ... , 76 );

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.