Support » Plugin: Postman SMTP Mailer/Email Log » Notices for Google API PHP client

  • Resolved simonbbrown


    Hi there,

    Firstly LOVE your plugin, however I am receiving a few notices whilst using the Google API for sending emails.

    Notice: Undefined offset: 1 in /wp-content/plugins/postman-smtp/Postman/Postman-Mail/google-api-php-client-1.1.2/autoload.php on line 20

    Using this in conjunction with Gravity Forms.

    Any chance we could get that resolved in the next version 🙂


Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jason Hendriks


    I would love to help you but I need more details on your problem. Do you know why the autoloader is being called without a classname? Unfortunately I did not write the google-api autoloader, Google did.

    What version of PHP are you using? On what operating system? Posting your Diagnostic Test output would help.

    I too am getting this same error with the latest version of gravity forms. The entire site is behind an SSL Certificate. And it happens on all three (3) forms on the site.

    PHP Version 5.3.29-pl0-gentoo

    If you need more pHp info it’s here:

    Notice: Undefined offset: 1 in /data/24/2/34/91/2686906/user/2950783/htdocs/wordpress/wp-content/plugins/postman-smtp/Postman/Postman-Mail/google-api-php-client-1.1.2/autoload.php on line 20

    Simple Contact form here:

    Contact Us

    Please help!

    I guess I should mention that the submissions are being mailed (emailed) fine!

    Except for the error; everything is working fine.

    I know this is a Google API Loader, but ANY HELP would be most appreciated – I can’t do this without Postman SMTP!

    Plugin Author Jason Hendriks


    That’s because it’s not an error, it’s a warning (notice).

    I don’t have Gravity Forms because it’s software that you have to buy. Obviously they are also loading the Google API, but not in a way that is compatible with Postman. Do you want to give me access to your site so I can test?

    Plugin Author Jason Hendriks


    Hello @ragtech is this still a problem? I have been trying to recreate it and I can not.

    Hi Jason
    I have a google email address e.g.
    In the postman setup, it seems I must change it to something else, say,
    Then I must Open the Google Developers Console Gmail Wizard and sign in with this new username.
    Google does not allow me…stating the following

    Sorry, Google doesn’t recognize that email. Create an account using that address?

    What am I doing wrong?

    Plugin Author Jason Hendriks


    What am I doing wrong?

    Why would give Postman the email to use if it’s not a real email? Use instead.

    ok tx. I get it… thought it was some address created to hide the real address from being seen. I did try with a real email as well. But then after selecting Go to Credentials below the message “The API is enabled”, I get another window
    API Credentials:
    You need credentials to access APIs. Enable the API’s you plan to use and then create the credentials you require. Depending on the API, you need an API key, a service account, or an OAuth 2.0 client ID.
    From this I have to select one of 3 options:
    API Key
    OAuth 2.0 client ID
    Service Account
    Why do I get this and what to select?

    Plugin Author Jason Hendriks


    I know it’s a little outdated now, but please watch the setup video included with Postman.

    Also read the FAQ, especially where it says ‘How do I get a Google Client ID? (For Gmail users only!)’

    You need to setup an OAuth 2.0 Client ID if you want to use OAuth 2.0.

    Plugin Author Jason Hendriks



    I was finally able to reproduce and fix this. Thanks for reporting.

    Thanks for not giving up where most would have!

    Postman SMTP is one awesome WP Plugin…

    Thank you for all that you do,

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Notices for Google API PHP client’ is closed to new replies.