Support » Plugin: Map Block for Google Maps » Notice / warning in widgets page

  • Resolved ehpastel

    (@ehpastel)


    Hello,

    Thanks for the nice plugin. When all notices / errors are enabled in the server, I get the following message on the widgets page:

    /wp-admin/widgets.php

    <b>Notice</b>: Function wp_enqueue_script() was called <strong>incorrectly</strong>. "wp-editor" script should not be enqueued together with the new widgets editor (wp-edit-widgets or wp-customize-widgets). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.8.0.) in <b>/home/user/http/wp_test/wp-includes/functions.php</b> on line <b>5831</b>

    If I remove ‘wp-editor’ from the map-block-gutenberg.php file (line 119), the message goes away.

    From what I can see, this is related to the new widgets page. Most likely the code needs to detect whether the old widgets page is enabled or not, and use ‘wp-editor’ or not. I thought I’d let you know, and you may want to get rid of that message.

    Many messages like this one appeared after WP version 5.8 related to other plugins too.

    Cheers

Viewing 1 replies (of 1 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    Yes, you’re right, we need to fix that. I’ve added it to the to-do and it’ll be resolved in the next release. Thank you for letting us know!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.