WordPress.org

Forums

Yoast SEO
[resolved] Notice: Undefined property: stdClass::$post_type (4 posts)

  1. dgfreemem
    Member
    Posted 1 year ago #

    Hi

    When activating WordPress SEO I get the following notice on top of my startpage (the product page of woocommerce):
    "Notice: Undefined property: stdClass::$post_type in /.../wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 159". When deactivating WordPress SEO the message disappears.

    Anyone know if there is a solution for this?

    I run these, all the latest, versions on my site:
    Wordpress 3.7.1–sv_SE
    WooCommerce 2.0.19
    WooDojo 1.5.4
    WordPress SEO 1.4.19

    http://wordpress.org/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 1 year ago #

    Sounds like another plugin is interfering with the wp_query object. Try disabling all other plugins and enabling them one by one to figure out which one is not resetting the wp_query object after use and file a bug report with them.

  3. dgfreemem
    Member
    Posted 1 year ago #

    Thanks jtf!

    Actually did just that but not as structured as you suggest. In my frustration I toggled things off and on and the message in not there anymore. Cant tell which one it was that did the trick though :/

  4. jrf
    Member
    Posted 1 year ago #

    Hi dgfreemem,

    Glad to hear you managed to get it working again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic