WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Notice: Undefined offset: 0

[Resolved] Notice: Undefined offset: 0

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Matt Lowe
    Participant

    @squelch

    Hi beaudaignault,

    Please post the code you are using on the page. Usually this is caused by an error in your shortcodes. Thanks, Matt.

    Beau Daignault
    Member

    @beaudaignault

    Right, I’m kinda new with the WP editor. (driving me nuts inserting paragraph tags everywhere!)
    the code as it is:

    [tabs title="" disabled="false" collapsible="true" active="0" event="click"]
    
    [tab title="definition”]My Ipsum[/tab]
    
    [tab title="is it for you?"]Tab 1 content[/tab]
    
    [tab title="what it does"]Tab 2 content[/tab]
    
    [tab title="meditation manual"]Tab 0 content[/tab]
    
    [tab title="seed of thought"]Tab 1 content[/tab]
    
    [tab title="meditation groups"]Tab 2 content[/tab]
    
    [tab title="group discussion topics"]Tab 0 content[/tab]
    
    [tab title="our hope”]One lorem Ipsum for mankind[/tab]
    
    [/tabs]

    Thank you!!

    Plugin Author Matt Lowe
    Participant

    @squelch

    All appears fine except for the quotes on definition and our hope. The closing quotes on each appear to be fancy 99-style quotes rather than straight quotes. In my test lab that causes issues.

    Also, do you have WP_DEBUG set to true in wp_config.php? There is a minor bug that causes that message to be displayed in the current version (fixed in my dev lab, not yet pushed out to the world) but it can be safely ignored.

    Beau Daignault
    Member

    @beaudaignault

    Yes, debug set to true in config. (development setting…)
    I did notice the one instance of fancy quotes- now I see the second, thanks.

    I’ll make some changes and post my results.

    Beau Daignault
    Member

    @beaudaignault

    Nah, I wrote the markup this time in my code editor, then pasted into WP editor (to help avoid styled quotes) – I still get the same ‘Undefined offset: 0…’ message.
    The are no other plugins active.
    We’ll see how she flies in production – hopefully in a few days.

    Thanks for your help!

    Plugin Author Matt Lowe
    Participant

    @squelch

    Is WP_DEBUG still set to true? There is a minor bug where a value is checked in an array, without first checking that the index has been set. It’s most likely just that. The next version will fix it (when I find time to release the next version!)

    Beau Daignault
    Member

    @beaudaignault

    Yes, when I turn off debug in the config, naturally the error, or, ‘notice’ is removed.
    Running a page on the local server (a mamp pro setup) that is using the tabs plugin and debug turned on in the config file produces: Notice!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Notice: Undefined offset: 0’ is closed to new replies.