Support » Plugin: wp-forecast » Notice: Undefined index: wpfcid error

  • Resolved thechiefalone

    (@thechiefalone)


    I am working on a intranet project thats why I can not share a link but I am getting this error on the home page top of the wp-forecast widget.

    Notice: Undefined index: wpfcid in /var/www/intranet_new/wp-content/plugins/wp-forecast/class-wpf_widget.php on line 43

    Can you help me ?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author tuxlog

    (@tuxlog)

    Hi,

    first of all this is not an error, only a notice and probably it is displayed because you configured WordPress to show notices too.

    If wpfcid is not defined you maybe did not create a location and select it in the admin widget dialog.

    can you conirm this?

    Plugin Author tuxlog

    (@tuxlog)

    seems to be resolved

    Thread Starter thechiefalone

    (@thechiefalone)

    Yes, thank you for your quick response. I realized that debug mode is opened and that’s why I am getting this error

    Hi, since two days I’ve some problems with the plugin.

    I have got the notice below:

    Notice: Undefined index: city in /home/q042n4b6/staging.bluekipos67.com/wp-content/plugins/wp-forecast/wp-forecast.php on line 119

    Notice: Undefined index: latitude in /home/q042n4b6/staging.bluekipos67.com/wp-content/plugins/wp-forecast/wp-forecast.php on line 140

    Notice: Undefined index: longitude in /home/q042n4b6/staging.bluekipos67.com/wp-content/plugins/wp-forecast/wp-forecast.php on line 141

    Even on the online page the plugin doesn’t work and show the selected location but “Notice: Undefined index: wpfcid in /home/q042n4b6/staging.bluekipos67.com/wp-content/plugins/wp-forecast/class-wpf_widget.php on line 43”

    I can confirm that I’ve correctly set:
    * Location (EUR|GR|GR000|VENERATON|
    * Latitude and Longitude
    * Use visitors location: enabled

    Thanks in advance!

    Plugin Author tuxlog

    (@tuxlog)

    Hi sissily71,

    in case you want to show the weather at the visitor location, please try empty location and latitute, logitude. In case you want to show the weather at Veneraton, please try disabling “Use visitors location”.

    Cheers, tuxlog

    Thanks a lot @tuxlog for your quick response.
    Now is all alright!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Notice: Undefined index: wpfcid error’ is closed to new replies.