Support » Plugin: WP Photo Album Plus » “Notice: Undefined index: has_searchbox in…” Error

  • Resolved typeadesign

    (@typeadesign)


    Hi, Jacob. I hope you can help us with this. When our users visit an album on our site, this error message has started appearing above the breadcrumbs to users:

    Notice: Undefined index: has_searchbox in /nas/content/live/addisonmag/wp-content/plugins/wp-photo-album-plus/wppa-functions.php on line 699

    I’ve tried changing any setting that has to do with a widget and a couple that have to do with search (the settings were changed back to their original state. I’ve cleared the object cache. Debug is enabled.

    I’ve included a link to one of the albums, but it displays on all of them.

    Please let me know what we need to do. Thank you, sir.

    • This topic was modified 1 year, 8 months ago by typeadesign.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I visited the page and did not see the Notice.

    When this notice appears, it tells me that the wppa session is not properly started.
    Run Table VIII-A1: Setup, to fix this.
    Look at Table VIII-C4 (Press the Show! button). It should read something like the following in the Data column:

    [ajax] => 0
    [display_searchstring] =>
    [has_searchbox] =>
    [id] => 513
    [isrobot] =>
    [page] => 1
    [photo] => Array()
    [rootbox] =>
    [search_root] =>
    [subbox] =>
    [superalbum] => 0
    [supersearch] =>
    [superview] => thumbs
    [use_searchstring] =>
    [user] => cron-job
    [wfcart] =>
    [randseed] => 2927
    [randseedtime] => 1553594328
    

    Notice [has_searchbox] => should show up here.

    Hi, Jacob,

    Thank you for your quick response! Unfortunately, that did not solve the problem. I followed your instructions several times. I downgraded to the previous release version 7.1.05.005 and updated to the most recent developmental version 7.1.06.008 and we get the same thing. Thinking it might be a CDN issue, I disabled our CDN, cleared the cache, and waited for it all to clear. We are still getting this notice.

    Here’s a link to a screenshot of the problem.

    I appreciate your help. Thank you, sir.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I know where the error is produced and i can simply avoid it, but i want to know what goes wrong. Therefor i asked you to show me the data colum of the session display from Table VIII-C4, preferrably the entire column of the one where it says: [user] => yourname near the bottom of the column

    Hi, Jacob,

    My apologies. I misread that part of your previous post. Here is the most recent cell from the Data column:

    [ajax] => 0
    [display_searchstring] =>
    [has_searchbox] =>
    [id] => 2308414
    [isrobot] =>
    [page] => 1
    [photo] => Array()
    [rootbox] =>
    [search_root] =>
    [subbox] =>
    [superalbum] => 0
    [supersearch] =>
    [superview] => thumbs
    [use_searchstring] =>
    [user] => 54.36.148.52
    [wfcart] =>
    • This reply was modified 1 year, 8 months ago by typeadesign.
    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Thanx!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Fixed in 7.1.06

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Notice: Undefined index: has_searchbox in…” Error’ is closed to new replies.