Support » Plugin: Product Specifications for Woocommerce » Notice on fresh woocommerce installation

  • I get this notice on activating the plugin:

    Notice: id was called incorrectly. Product properties should not be accessed directly. Backtrace: require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/storefront-child/woocommerce/single-product.php’), wc_get_template_part, load_template, require(‘/plugins/woocommerce/templates/content-single-product.php’), do_action(‘woocommerce_after_single_product_summary’), WP_Hook->do_action, WP_Hook->apply_filters, woocommerce_output_product_data_tabs, wc_get_template, include(‘/plugins/woocommerce/templates/single-product/tabs/tabs.php’), apply_filters(‘woocommerce_product_tabs’), WP_Hook->apply_filters, DW_specs->woocommerce_tabs, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong Please see Debugging in WordPress for more information. (This message was added in version 3.0.) in /var/www/html/wp-includes/functions.php on line 4161

Viewing 2 replies - 1 through 2 (of 2 total)
  • Open file wc-specs.php and go to line 142 and replace lines:

    if( dw_product_has_specs_table( $product->id ) ){

    to

    if( dw_product_has_specs_table( $product->get_id() ) ){

    next go to line 150 and replace

    if( get_option('dwps_wc_default_specs') == 'remove' || ( dw_product_has_specs_table( $product->id ) && get_option('dwps_wc_default_specs') == 'remove_if_specs_not_empty' ) ) {

    to

    if( get_option('dwps_wc_default_specs') == 'remove' || ( dw_product_has_specs_table( $product->get_id() ) && get_option('dwps_wc_default_specs') == 'remove_if_specs_not_empty' ) ) {

    Thank you for your quick solution.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Notice on fresh woocommerce installation’ is closed to new replies.