Support » Plugin: Code Snippets » Notice: Code Snippets 2.5 will require PHP 5.4

  • Plugin Author Shea Bunge

    (@bungeshea)


    Hello everyone,

    This is a notice to let users of this plugin know that beginning with the next version, 2.5.0, Code Snippets will require PHP 5.4 in order to run. Previous versions will work as they do now, but will no longer receive updates for fixes.

    If your WordPress site runs on an older version of PHP (5.2, 5.3), then please make sure you upgrade as soon as possible. These versions of PHP are outdated and unsupported by the PHP team, so they will not receive any important security updates. If you are not sure how to upgrade, please ask your web host for help.

    https://wordpress.org/plugins/code-snippets/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Shea Bunge

    (@bungeshea)

    I’ve decided that version 3.0.0 will be the first to require 5.4, not 2.5.0. However, I still recommend that you upgrade as soon as possible.

    Hello

    Can you tell me if this plugin has been tested with PHP 7 and is compatible with PHP 7?

    Our server will be upgraded to run the latest version when it is released. So we are checking the compatibility of all our plugins prior to the upgrade.

    Thank you

    Simon

    Plugin Author Shea Bunge

    (@bungeshea)

    It should run fine in PHP 7; I can’t see anything that would be incompadible. I’m in the process of upgrading my local development and live servers to PHP 7 as well, so I’ll know if something breaks.

    Thanks for letting us know 🙂

    Hi,

    When i login to my wordpress dashboard it’s very slow and times out. I get a 504 gateway time-out error.

    I’m trying to figure out what the problem is and my host has suggested it is one of my plugins, so they suggested i rename them one by one to see which one is the problem.

    I’m going through my plugins via FTP and see I have Code Snippets installed, but i can’t recall why i installed it or what it does for me, so i’m not comfortable renaming it incase it causes irreversible damage to my website. Is this possible? I use Pageline DMS theme if that helps.

    On this forum I see your latest version of Code Snippets requires PHP 5.4. I logged into Crazy Domains and see I have PHP 5.1.73.

    I installed Code Snippets version 1.9.1.1.

    Any feedback you think will be helpful is appreciated.

    Thanks for your time.

    Jason.

    Plugin Author Shea Bunge

    (@bungeshea)

    Hi Jason,

    At the moment, the present version of Code Snippets (and all past versions) work fine on PHP 5.2. This PHP 5.4 notice will apply when version 3.0.0 is released.

    PHP 5.1 is a very old version, and is not even supported by WordPress. This is likely the cause of your issues you are facing. I recommend you contact your hosts about upgrading the PHP version immediately. The more recent, the better, though you should at least have version 5.2 or greater, and it’s best to use version 5.5 or later.

    Generally speaking, Code Snippets plugin should be safe to disable and remove – it won’t do irreversible damage. It really depends on which snippets you have added. These can be viewed on the Snippets admin menu. Before removing the plugin, please ensure that all of these snippets are either backed up or no longer needed.

    One last thing: as a favor, if you have any future issues could you please start a new topic in the forum instead of adding to a current one. It makes it easier to address your issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Notice: Code Snippets 2.5 will require PHP 5.4’ is closed to new replies.