Support » Plugin: Cerber Security & Antispam » Notice and Warning messages in place of home page

  • olaflexemo

    (@olaflexemo)


    I have three identical instances (cloned them using updraftPlus). One of them has a problem with Cerber by the looks of it. Instead of showing the home page i get the following two error messages displayed:

    Notice: Trying to get property of non-object in /var/www/html/wp-content/plugins/wp-cerber/wp-cerber.php on line 1040

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wp-cerber/wp-cerber.php:1040) in /var/www/html/wp-includes/pluggable.php on line 1210

    When I navigate to a page directly I do see my content though.

    Any idea?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Gioni

    (@gioni)

    Hi!

    Please, try this first: http://wpcerber.com/repair-database-tables/ and let me know how’s it goes.

    olaflexemo

    (@olaflexemo)

    Hi Gioni,

    sorry, I should have mentioned it but I did try this already a couple of times.
    It doesn’t change anything.

    Thanks,
    Olaf

    avpman

    (@avpman)

    Generally, it’s been my personal experience that the “Warning: Cannot modify header information – headers already sent by (output” is the result of one or more white spaces at the beginning of the PHP code. For example if the code started with a blank line, or even a space before the php tag in the code:
    <?php>
    That will cause this error. Somewhat unlikely int his case since Gioni is a excellent coder. But something may have happened to the plugin code upon upload. He would be best to address the issue.

    olaflexemo

    (@olaflexemo)

    Thanks for the tip. I have deleted and re-installed the plugin a few times already, that should have taken care of potentially corrupt php files in my instance. I also deleted all the cerber tables before re-installing to no avail.
    I guess it has something to do with restoring the instance with a backup from another instance. But I have another ‘child’ instance where the same process worked just fine…

    Plugin Author Gioni

    (@gioni)

    That’s weird: “But I have another ‘child’ instance where the same process worked just fine…”.

    Please make sure that you have the same plugins and theme active. In your case, something wants to redirect your browser to some location but the plugin is not yet initialized properly at that time and this leads to the issue. Usually, redirections happen after plugins are initialized completely.

    Make sure also that WordPress Address (URL) of your new instance is correct.

    I was getting the same error, and @avpman your note about removing whitespace at the beginning of the file solved it. Thank you!!

    Great! Which specific wpcerber .php file had the white space in it?

    P.S. I’ve been bitten by that bug in my own programming so many times I can’t count!

    Problem still persists. In total I have 4 cloned sites. Cloning done using UpdraftPlus Backup. Cerber works fine on three of these sites but still fails with the same error when trying to go to the home page on that one site… 🙁
    used a search and replace plugin to check for old urls. WordPress URL also checked – still no luck.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.