Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Nothing works when multiple roles

  • I am using the “User Role Editor” plugin. I am using this site to test your Ultimate Member plugin to use in a number of other sites I own. Your plugin does not work at all when using multiple roles per user. It looks like this is because the members directory uses the roles parameter and breaks when multiple roles exist. Please add a for loop to this code to handle multiple roles.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Further to my above comment when removing the multiple user role plugin the data in the Ultimate Member plugin becomes corrupt resulting in the need to reste the whole sites user data !

    I used to use the ‘Members’ plugin with UM 1.3.88 with no dramas, for what it’s worth.

    They seem to have done some fixes so at least it shows results and does not crash now when doing a search. However searching under tags such as language does not seem to filter results. It just simply shows the results filtered by role. When editing the role of user and saving. It saves the role as null. This is quite a serious bug as I reset a user from student to teacher which was also an admin and it set the role to null.

    • This reply was modified 1 year, 2 months ago by  moleisking.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Nothing works when multiple roles’ is closed to new replies.