Support » Plugin: OSMapper » Nothing works anymore : Javascript Error – Backend

  • Resolved stonex1912

    (@stonex1912)


    After updating to the latest version nothing works anymore.

    -WP-5.2.3
    -OSMapper: 1.9.1.4
    -OSMapperPro: 1.7.2

    Console:
    osmapper_leaflet.js?ver=1.9.1.4:1 Uncaught TypeError: Cannot read property 'lat' of undefined
        at b.getNorth (osmapper_leaflet.js?ver=1.9.1.4:1)
        at renderMap (osmapper_renderer.js?ver=1.9.1.4:458)
        at HTMLDocument.<anonymous> (osmapper_renderer.js?ver=1.9.1.4:78)
        at HTMLDocument.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at HTMLDocument.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at Object.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at Object.a.event.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:8)
        at x (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:4)
        at XMLHttpRequest.c (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:4)
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author b4after

    (@b4after)

    Ply try install latest version 9.10 we hope it will solve your problem. We are waiting for your feedback.

    Thread Starter stonex1912

    (@stonex1912)

    Same error:

    osmapper_leaflet.js?ver=1.10.0:1 Uncaught TypeError: Cannot read property 'lat' of undefined
        at b.getNorth (osmapper_leaflet.js?ver=1.10.0:1)
        at renderMap (osmapper_renderer.js?ver=1.10.0:458)
        at HTMLDocument.<anonymous> (osmapper_renderer.js?ver=1.10.0:78)
        at HTMLDocument.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at HTMLDocument.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at Object.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:3)
        at Object.a.event.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:8)
        at x (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:4)
        at XMLHttpRequest.c (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload,jquery-ui-r&load[]=esizable&ver=5.2.3:4)
    Plugin Author b4after

    (@b4after)

    We need more detail. Are you sure you have latest versions of plugins? Did you clean cache?

    • This reply was modified 2 years, 8 months ago by b4after.
    • This reply was modified 2 years, 8 months ago by b4after.
    Plugin Author b4after

    (@b4after)

    We are currently investigating it you have to be patient.

    Plugin Author b4after

    (@b4after)

    Can you try to add new map with new marker on latest version?

    Thread Starter stonex1912

    (@stonex1912)

    Ok, switch to a clean browser and add a new (clean) map, now it seems to work.

    WP 5.2.3
    OSMapper 1.10
    OSMapperPro 1.7.2

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Nothing works anymore : Javascript Error – Backend’ is closed to new replies.