Support » Plugin: Wordfence Security - Firewall & Malware Scan » Nothing working in Wordfence

  • Resolved artisanweb

    (@artisanweb)


    My client’s website just got hacked again. I checked Wordfence and there was a scan yesterday showing 106 results found but it doesn’t list them. I click on Start a new scan and nothing happens. I go to Tools > Diagnostics and trying clicking on any of the items and nothing happens. Click on Expand all Diagnostics – nothing. Just about everything I try to click on nothing happens. I’ve tried deactivating and reinstalling Wordfence through plugins. I’ve tried deleting Wordfence via FTP and reinstalling. It doesn’t seem to totally delete as it still says there are 106 results. WordPress version 4.9.8.

    Any ideas?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @artisanweb,

    Can you check off Delete Wordfence tables and data on deactivation, and then deactivate Wordfence and reinstall Wordfence?

    Example: https://i.imgur.com/l9PsbTD.png (Wordfence -> All Options -> General Wordfence Options)

    From a fresh install of Wordfence, please let me know if the scans run.

    Dave

    I’m not able to tick anything. I tick it but nothing happens (the tick doesn’t appear). The Save Options button is also blank. There’s a “restore defaults/Cancel” at the top but clicking on this nothing happens.

    Plugin Support wfdave

    (@wfdave)

    Can I have you remove all tables related to Wordfence with the following SQL query?

    SET GROUP_CONCAT_MAX_LEN=10000;
    
    SET @del = (
        SELECT      CONCAT('DROP TABLE ', GROUP_CONCAT(TABLE_NAME), ';')
        FROM        information_schema.TABLES
        WHERE       TABLE_SCHEMA = 'wordpress'
        AND         TABLE_NAME LIKE 'wp_wf%'
    );
    
    PREPARE stmt FROM @del;
    EXECUTE stmt;
    DEALLOCATE PREPARE stmt;

    From here, reinstall Wordfence and it should recreate the tables.

    Dave

    Plugin Support wfdave

    (@wfdave)

    Hi again!

    We haven’t heard back from you in a while, so I’ve gone ahead and marked this thread as resolved.

    Please feel free to open another thread if you’re still having issues with Wordfence.

    Note: You can also install the Wordfence assistant plugin to help with deleting tables if running the query is not possible.

    Dave

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Nothing working in Wordfence’ is closed to new replies.