WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Nothing will update “automatically”

[Resolved] Nothing will update “automatically”

  • This is a problem that I’ve had for a while but put up with it until now when I wanted to upgrade WordPress. The problem happens with plugins too.

    Anyway, I have the message at the top saying “WordPress 2.8.6 is available! Please update now.” when I click on update now and choose “upgrade automatically” it then asks me for FTP username/password. I enter the details and all I get is a message that says:

    Downloading update from: http://wordpress.org/wordpress-2.8.6.zip

    Unpacking the update

    Unpacking the update

    And it just stops there and does nothing. Stops loading, even if I leave it for 5 minutes and click on the Dashboard it just says “WordPress 2.8.6 is available! Please update now” like before.

    Same thing happens when I try to upgrade plugins, it says it’s unpacking the update but just stops and does nothing.

    Any help would be appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Shane G.

    @shane-g-1

    Hi,

    Check with these options:

    -> disable all the plugins and then have a check with upgrade.
    -> Add this code in htaccess and have a try;

    php_value memory_limit 64M

    Thanks,

    Shane G.

    I’ve disabled all plugins and no change. When I put that code in htaccess I get Internal Server Errors.

    I even changed the theme to the wordpress default in case the newest theme I was using was somehow affecting it.

    I’ve checked cpanel and wordpress IS downloading the update zip to my server and creating the folders in the “Upgrade” folder but it’s not actually completing the update – or “unpacking it”.

    Persistence seems to have somehow worked?

    Downloading update from http://wordpress.org/wordpress-2.8.6.zip.

    Unpacking the update.

    Verifying the unpacked files

    Installing the latest version

    Upgrading database

    Upgrading database

    It stopped at the upgrading database part, but I click on dashboard and it says it’s upgraded and running 2.8.6

    Weird stuff =/

    All I did was reactivate the plugins and delete the duplicate update folders on the server and try one final time to upgrade automatically. Seems to have worked.

    esmi

    @esmi

    Forum Moderator

    1. Try adding:

    AddType x-mapp-php5 .php

    to the top of your .htaccess file.

    2. If you have access to your php.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    3. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '32M');

    i’ve been having problems unpacking my plugins since around 2.8.

    after upgrading to 2.9.1, i did the following 2 things from above, and now everything is updating nicely:

    -> Add this code in htaccess and have a try;
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’32M’);

    I’m having a similar issue. I hit “upgrade automatically” and it takes me to a blank page. I am not proficient in PHP, but i could not locate any of those files mentioned above.

    Can someone provide layman instructions?

    Thanks!

    dgivista’s recommendation did the trick for me. Prior to the change I would get Downloading update from http://wordpress.org/wordpress-2.9.1.zip and then the page would complete to DONE.

    -> Add this code in htaccess and have a try;
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’32M’);

    Setting define(‘WP_MEMORY_LIMIT’, ’32M’) alone was not enough to get it to work; it required both.

    Cheers,
    Trip

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Nothing will update “automatically”’ is closed to new replies.
Skip to toolbar