Support » Plugin: Asset CleanUp: Page Speed Booster » Nothing unloads when I unload css/javascript saving not saved

  • elextric

    (@elextric)


    Hello,

    I installed Asset cleanup, it finds all the scripts on my home page.
    I select the switches to unload assets, and click save.
    The page says it saved and WordPress reloads the backend, yet all the switches reset to not being selected.

    Any idea how to fix this?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @elextric when you manage the assets for the “Homepage” tab from “CSS & JAVASCRIPT LOAD MANAGER”, what’s the URL that you see near “Page URL:”?

    Sometimes, $post is overwritten by external plugins or the theme because the developers have forgotten to use wp_reset_postdata() and reset it to its initial value (which should be 0 in this case). This was fixed and pushed for tag 1.3.4.2. If you see a different URL there, this could be the issue and you just have to update the plugin to the latest version. If the URL is correct, then the problem is different and we can dig into it further.

    Also, where are you managing the assets? From the Dashboard or in the front-end view? Some print screen images would be useful (you can use a service like https://imgbb.com/ to upload the images).

    elextric

    (@elextric)

    Hi Gabe,

    Thanks for the help.
    I updated the plugin but still have same issue.

    Here is a screenshot of the backend:
    https://prnt.sc/p5859z

    I select to disable something, e.g.
    https://prnt.sc/p585oi

    Then press Update

    But then the page reloads and I see this:
    https://prnt.sc/p586ay

    I’ve tried with other css files and js but they all behave the same way!

    Thanks again for troubleshooting.

    Best

    Gary

    Plugin Author Gabe Livan

    (@gabelivan)

    @elextric if it behaves like this with one CSS/JS file, it will be like that for all because the same coding patterns apply to all of them. It could be a conflict between plugins/theme.

    Can you actually check if the unloaded JS is actually unloaded when you visit the home page? Perhaps it’s saved in the database, but for some reason, not showing up. Also, it would be good if you can enable the option “Manage in the front-end” in “Plugin Usage Preferences” and see if it works unloading the assets on the front-end view (bottom of the page)? You can use it until I debug the back-end. I have to admit that I’m really surprised about this and you made me curious what plugin/theme you’re using that could cause such as conflict.

    Hi Gabe,

    Thanks again so much for your time looking at this,
    I’ve tried what you suggested.

    Firstly this is to check if the file is unloaded from the homepage even though backend says it’s not.
    The file is not unloaded.
    Here are the steps I took:

    https://prnt.sc/p8dv0a – file before switch set (present on homepage)
    https://prnt.sc/p8dvlv – set switch
    https://prnt.sc/p8dw4c – I press this button (switches resets to enabled)
    https://prnt.sc/p8ek7o – Then refresh and script still loaded

    Secondly I set the option to manage in the frontend

    Then repeated the process at the bottom of the page, by unchecking one of the scripts:

    https://prnt.sc/p8elq8

    But the same thing happened, nothing was unloaded. The switch reset, and the css is still in the inspector!

    Do you have any other ideas?

    Best,

    Gary

    Plugin Author Gabe Livan

    (@gabelivan)

    @elextric I’ve checked your print screens and without knowing more about your server’s configuration, I can’t debug it further as this is an isolated case.

    Can you send me your “System Info” text file from “Tools” (plugin’s menu) via https://gabelivan.com/contact (as you have private information there that you may not want to share it publicly)? I can dig into it and take it from there!

    It could be an incompatibility with a plugin or the theme somewhere and I’m keen to find out what’s going on there.

    Thank you, again appreciated. Will have this sent within 24 hours.

    Hi again,

    I have sent this now,

    Thanks

    Hi just wondering if you had a chance to check this yet?

    Thanks

    Gary

    Plugin Author Gabe Livan

    (@gabelivan)

    @elextric thanks for the reminder! The past days happened to be very busy so my apologies for not getting back sooner! I’m on it and I’ll get back to you as soon as possible.

    Plugin Author Gabe Livan

    (@gabelivan)

    @elextric thank you for providing your “System Info”! I replied to your email. We can continue the conversation there.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.