WordPress.org

Forums

Facebook
[resolved] Nothing shows on profile page (6 posts)

  1. Philip John
    Member
    Posted 2 years ago #

    I've just installed the plugin and attempted to set up the Social Publisher.

    When I click on the "Add a Facebook account to your WordPress account" link I am taken to my profile page but all I see is a Facebook Account heading with "Get started" below.

    It looks as though there should be a "Connect to Facebook" plugin beside it but there is nothing. I checked the HTML - the table cell there is blank.

    I'm on v1.5.2, WP v3.6 and I switched off all other plugins and reverted to the default theme but still have the same issue.

    Any ideas?

    http://wordpress.org/plugins/facebook/

  2. Niall Kennedy
    Member
    Plugin Author

    Posted 2 years ago #

    Have you configured your Facebook account for the domain of your WordPress administrative interface?

    1. Visit the apps section of the Facebook developer site
    2. Select the application associated with your WordPress account.
    3. Enter your app's domain: e.g. example.com
    4. In the Select how your app integrates with Facebook enter the URL of your homepage: e.g. http://example.com/
    5. Save changes.
  3. Philip John
    Member
    Posted 2 years ago #

    Thank you, that solved it.

    That really should be included in the list of prerequisites as otherwise there's no indication whatsoever that that step is necessary.

    It would also be much simpler if the authentication could happen from the Social Publisher page rather than having to go through the user profile too, which just lengthens the process unneccessarilly.

    Thanks

  4. Niall Kennedy
    Member
    Plugin Author

    Posted 2 years ago #

    Social Publisher page is accessible to site administrators. Edit profile page is available to site authors. A common use case for larger sites is a WordPress user capable of writing a post but not managing the site. Extending the profile page locates Facebook features for the author alongside other information possibly used to represent the author on the site and only requires the viewer to have permission to edit his own profile.

  5. fouldsy99
    Member
    Posted 1 year ago #

    In the Select how your app integrates with Facebook enter the URL of your homepage: e.g. http://example.com/

    I can't find this option

  6. emanuelebellini
    Member
    Posted 1 year ago #

    That's because the website is different now.
    In my app dashboard on the Facebook developer page I clicked "Settings", then "Add Platform". After selecting "website" I added its URL in the new apposite box, then in the "App Domains" box I entered the URL without "http://www".
    Fine, that worked for me! Now I've got the options to connect a Facebook account in the profile settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.