Support » Plugin: Analytify - Google Analytics Dashboard Plugin for WordPress » Nothing Showing Geographic Panel

  • Resolved 11whyohwhy15

    (@11whyohwhy15)



    To comply with GDPR we updated our site to HTTPS and since then all our details in the Geographic panel have disappeared and it is now blank and has been for 3 days now ?

    We did go to google analytics and console panel and add the new HTTPS pages for our site

    We’ve cleared all our caches…

    Any thoughts ?

    Thanks

    • This topic was modified 2 months, 3 weeks ago by  11whyohwhy15.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Burhan Nasir

    (@burhandodhy)

    Hi 11whyohwhy15,

    Sorry for the inconvenience. There could be 2 reasons either there is no data on Google Analytics or there is confliction with another plugin.

    To make sure is the data is available in Google Analytics.
    1) Go to https://analytics.google.com/
    2) Click on Audience -> Overview
    3) Click on County under the Demographic section http://prntscr.com/jnh4s9

    To check if there is confliction.
    1) Go to Analytify Dashboard.
    2) Press Right Click and then Inspect option.
    3) Click on Console tab and check is there any JavaScript error ?

    Look forward,

    HI,

    OK it’s showing now but I have this message at the top of the Geographic panel screen?

    Error calling GET https://www.googleapis.com/analytics/v3/data/ga?ids=ga%3A134422531&start-date=2018-04-28&end-date=2018-05-28&metrics=ga%3Asessions&dimensions=ga%3Acity%2Cga%3Acountry&sort=-ga%3Asessions&filters=ga%3Acity%21%3D%28not+set%29%3Bga%3Acountry%21%3D%28not+set%29&max-results=5: (403) Quota Error: User Rate Limit Exceeded.

    In console I’m getting this :

    Uncaught SyntaxError: Unexpected token < in JSON at position 0
    at JSON.parse (<anonymous>)
    at Function.n.parseJSON (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:4)
    at Function.a.parseJSON (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:9)
    at Object.success (<anonymous>:7:29)
    at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:2)
    at y (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:4)
    at XMLHttpRequest.c (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,jquery-touch-punch,underscore,wp-util,jquery-ui-tabs,moxiejs,plupload&ver=4.9.6:4)

    Any idea ?

    Thanks

    OK… Ignore details above now.

    Geographic panel disappeared again with this error in Google console:

    rocket-loader.min.js:1 [ROCKET LOADER] Activator script doesn’t have nonce. No scripts will be executed.
    e @ rocket-loader.min.js:1
    (anonymous) @ rocket-loader.min.js:1
    (anonymous) @ rocket-loader.min.js:1
    (anonymous) @ rocket-loader.min.js:1

    I went to cloudflare and switched off Rocket Loader and it all works fine?

    Problem is I’ve never had this problem before switching to HTTPS ? and Rocket loader speeds up my site by loading java script pages faster…

    So any idea if this can be fixed without switching Rocket Loader off ?

    Thanks

    Plugin Support Burhan Nasir

    (@burhandodhy)

    Hi,

    We never tackle this problem with “ROCKET LOADER” before. So I’m going to investigate it and will let you know once I get something.

    Ok will wait for your reply.

    Thank you

    This is not resolved ?? I’m waiting for you to tackle ‘Rocket Loader’ problem as stated by Burhan Nasir above!

    Thanks

    Plugin Author Adnan

    (@hiddenpearls)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Nothing Showing Geographic Panel’ is closed to new replies.