Support » Installation » Nothing on the main page… everything else is A-OK.

Nothing on the main page… everything else is A-OK.

  • Simple problem to describe- but it’s eating my lunch.
    I’m using a reseller account through MochaHost.
    I’m trying to setup clients WordPress accounts.
    I got the first one up and running with no problems. MochaHost provides a temp URL, which is what I will be posting here. My first site worked fine with that URL- so that is not the issue.

    When I go to
    — I get a blank page. This is what I see after installing a WP site with the MochaHost install wizard. Very few options.

    Now, if I go to
    — I am first met with the “setup your blog for the first time” stuff- and then can easily log in. I can add posts. Delete the test comments. change my theme. Download plugins. But nothing ever makes the front page work. When I click on Dashbaord, it correctly sends me back to http://indianapoliswithkids.com.cws5.my-hosting-panel.com — and there is nothing there.

    MochaHost says there is nothing they can do about it. It must be a WordPress problem. (I also can update my WP version from 3.0 to 3.1 — MochaHost only let’s me do 3.0 as the initial install, but after the update it still doesn’t work)

    I hope someone knows what’s up. This is driving me crazy.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff


    There is probably an index.html or home.html file in the same directory as the WordPress index.php file. Remove the index.html or home.html file, either via FTP or your hosting provider’s file manager, and all should be fine.

    If that is not the problem, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Ten theme to rule-out a theme-specific issue.

    there is no index.html or home.html.
    I should have said that I have tried adding “index.php” at the end of the URL, and the symptoms do not change.

    Only the default two plugins are installed- the two that come with a fresh install- hello dolly and akismet. both are deactivated by default, and I have not messed with them or any others since install.

    It’s already on the Twenty Ten theme, but I randomly grabbed “Suffusion” this morning, installed and activated that, and no changes.

    Here is the code of my index.php file:
    * Front to the WordPress application. This file doesn’t do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    * @package WordPress

    * Tells WordPress to load the WordPress theme and output it.
    * @var bool
    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */

    Here is the code of my wp-blog-header.php file:
    * Loads the WordPress environment and template.
    * @package WordPress

    if ( !isset($wp_did_header) ) {

    $wp_did_header = true;

    require_once( dirname(__FILE__) . ‘/wp-load.php’ );


    require_once( ABSPATH . WPINC . ‘/template-loader.php’ );



    Same issue on the same hosting. Home page is just blank after a clean install. All other pages shows standard “let’s create a config” wizard.

    It seems that including files without full path does not work on mochahost.

    I replaced
    require( dirname(__FILE__) . ‘/wp-blog-header.php’);

    Sorry, I’m not a php developer, and cannot tell you why that fix works 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Nothing on the main page… everything else is A-OK.’ is closed to new replies.
Skip to toolbar