Support » Plugin: Z-URL Preview » Nothing inserted into post.

  • “Eye” button has appeared on editor toolbar after installing plugin.

    When I click the “eye” button, the dialog box opens and I enter the URL and click “OK”.

    Then nothing! Nothing entered into the post (both visual and text mode).

    I can see the plugin’s settings, just nothing appears in the post.

    https://wordpress.org/plugins/z-url-preview/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author StuartMillington

    (@stuartmillington)

    Make sure you’re running the current version of the plugin with CURL debug included. If you are and CURL errors, e.g. firewalls or DNS issues, then it should return that error in the post body.

    Hi, this plugin started out great. But I now find it only works on some of my themes.
    *Is there something I need to add into the code?
    *I am using child themes.
    *all my plugins, tinyMCE and Wp are up to date.
    *I have tried moving the Eye Button up and down on different lines of the editor too. Still doesn’t work.
    *The eye button is there, and the url box pops up when I click the eye, I paste in my URL (a URL that works on another Z-URL link on different site/theme),
    then enter, and then nothing happens, no code, no error message either.

    Plugin Author StuartMillington

    (@stuartmillington)

    This is one thing I’ve never been able to reproduce. (Aside from the time I had the editor in text mode rather than visual mode for a day. DOH!) It does only work in visual mode though.

    There should be nothing you need to add. I use child themes too and it works for me. Both “old” themes and the new 2017 one. Moving the button shouldn’t change the insert behaviour.

    Two Q’s I can think of:

    1)What happens if (in visual mode) you type rubbish into the url box, like “asddag”? It should give you the CURL error details.

    2) Do you get anything in the console log?

    …and one random thought – which may not make sense – but, is there anyway that the non-working themes could be “forcing” the editor into text mode?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Nothing inserted into post.’ is closed to new replies.