Support » Fixing WordPress » Nothing in my WP database?

  • My site ( has been acting up for about two weeks, throwing this error after I updated to Pagelines 2.2.1:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 19456 bytes) in /homepages/41/d390445773/htdocs/app390445789/wp-content/themes/pagelines/includes/library.functions.php on line 948

    I can’t even access my WP admin page. I’ve been through the dance with my host, 1&1, and I think it’s come down to a problem with 1&1’s “Click & Build” WordPress installation and its limitations when it comes to modifications like new templates and plugins. I’m thinking about just deleting it all and re-installing WP 3.4.1 manually. I’ve backed up my site and database, but when I check my database through phpMyAdmin, it shows that I’ve used 0.00MB of my 1,024MB Total Storage Space.

    How can this be possible since I know I have content on my site? I don’t want to do anything if my posts, permalinks, etc. aren’t going to be restored properly or even be deleted.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Mark Ratledge


    Forum Moderator

    You don’t need to delete/reinstall WordPress.

    1&1 is well known for limiting account php memory. Using FTP you can try increasing the memory for PHP by adding the “define” line below near the top of your wp-config.php file. Put it a few lines of white space below the opening <?php

    define('WP_MEMORY_LIMIT', '64M');

    If that doesn’t work, you need to upgrade to an account there that gives more memory, or move to a better web host. Recommended WordPress Web Hosting

    Thanks for the reply, @songdogtech. I’ve actually already increased it to 128M, but it’s still not working! I know for a fact that the new Pagelines framework requires no more than 40M php memory, so that’s what’s fishy on that front…

    Do you know what might be happening with my database apparently not having anything in it?

    Moderator Mark Ratledge


    Forum Moderator

    1&1 doesn’t give you more than 32 megs, no matter what.

    Are you looking at the correct database?

    @songdogtech that’s crazy! How do they expect anyone to run a professional site on their servers???

    Yea it’s got to be. I only have one database set up. From my 1&1 Control Panel I go to MySQL Administration. My database is listed right there, then I go to phpMyAdmin and go follow WordPress’s steps in the codex to back it up. Once I’m in there, however, there isn’t anything listed in the tables, so that’s another thing that is confusing me.

    Again, thanks for your help so far!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Nothing in my WP database?’ is closed to new replies.