Support » Plugin: Custom Icons for Elementor » Nothing happens when I upload a file!

  • Plugin Author Michael Bourne

    (@michaelbourne)


    That’s frustrating, I know. Here are some tips if this happens:

    1) Make sure you are uploading a ZIP file downloaded from the Fontello.com website. No other file format will work.

    2) Make sure you give that font family a name, right beside that download button on Fontello. A unique name is needed for each font.

    3) Ask your host if there were any security rules triggered by mod_security, and ask them to bypass if so.

    4) Ask your host if any errors were generated, such as their PHP install not supporting ZipArchive and it’s components.

    If none of those 4 above are the issue, it may require further investigation. But to date, between two branches of this plugin for two page builders, the above steps have resolved every single support question.

Viewing 10 replies - 1 through 10 (of 10 total)
  • On my VPS i needed to run:

    sudo apt-get install php7.0-zip

    and then

    systemctl restart apache2

    to get it work.

    Related to point (4).

    I have the same issue!

    I tried all of this steps and it’s still not working

    I select or drag the zip file
    then the progress bar completes
    but then nothing happens.

    Checking with inspector, I found that
    I get a 500 internal server error, from /wp-admin/admin-ajax.php (method: post)

    I have PHP Version: 7.2.8

    • This reply was modified 4 months, 3 weeks ago by  saparreira.

    I finally figured out.

    My server’s PHP configuration had ZIP disabled. After enabling it, it started to work.

    mara12

    (@mara12)

    Hi your plugin worked perfectly on my website. I decided to add one more icon in a while and now nothing happens. Old icons remain the same. How can I fix this?

    • This reply was modified 1 month ago by  mara12.
    • This reply was modified 1 month ago by  mara12.
    Plugin Author Michael Bourne

    (@michaelbourne)

    Hi @mara12

    Can you be a little more specific about what is or isn’t happening?

    Are you saying that you’re uploading a brand new Fontello ZIP file and the icons aren’t showing?

    I was having the same problem & enabling zip uploads through cpanel solved my problem!

    Thanks @saparreira

    Thanks @saparreira this was my problem too.

    Glad that sharing the experience has helped others as well

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.