Support » Plugin: Salt Shaker » Nothing happens

  • Resolved jfsberg

    (@jfsberg)


    Hi,
    installed Salt Shaker on a demo site to test it out.
    Activated it and in Settings I chose Immediate change and counted on having to log in again. Nothing happened.
    OK, let´s try scheduling, ticked the box and set it to Monthly. Logged out, went to Settings again, it still says Daily.
    I couldn´t find a Save button or is it automatically saved?
    To sum it up, nothing happens when trying different settings.
    Can you help me? Thanks.
    Jan

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Nagdy

    (@nagdy)

    @jfsberg first things first, it auto-saves the settings.

    Can you please open your wp-config.php file and check if you have some salt keys? They’ll look something like this:

    define('AUTH_KEY',         '+2LoS2JVBGhJ0Jrg9qlgpkLV9MiAJ+j1lQBRmk1imycpujc8TFcJ9tfT1BLPoIfckrEiOxX0bjj9H+igr8u8Ug==');
    define('SECURE_AUTH_KEY',  'zohCO5I4URWGWuZW25L5kP5WgilG9b0qD5w5dQHO5jKoBSHIa+1q/y9SBU/Cu0JIbNuv70G+p9PLvhK2mPyCCQ==');
    define('LOGGED_IN_KEY',    'QJ5XquQvrS+F8YueWyhVuIWSCmerh6ONJmC2DxZ6QUGDNyGtqPdhGoRSNQg9ekMf3XPIvfhyWCtYfXCeWWi7yw==');
    define('NONCE_KEY',        'zgaEcD3svYHyB21C5u8t4VGBlsqrLsdV7K5g+YbpOeAo+rMYKjfNu2I2G+hCnE2FSQvPAZSKRa2OmQvakHr6ow==');
    define('AUTH_SALT',        '76lTyi795JQnyuw3AnE+srzzUOnhN1GdIqjinFbwbvfKmEpGJyUuEF2FSsqrRSCsGdYgMansNOaw9g5elczUgg==');
    define('SECURE_AUTH_SALT', 'Z+yV/cvkr3L763TUjTA+oa1wMiZi9RbrCAc5GsNgOPhe3w1k8fU7ftu0cvRWrfScgJIbPfOlYfxQdY+/pIMEAg==');
    define('LOGGED_IN_SALT',   'IfcNWpTL3OcZrMo4I1IbZoxT5MVgmvCsYpI1kOrp/sziJdFt8056J1jIfc3nxhwAEkUGdkUaFChla9LKOVILEA==');
    define('NONCE_SALT',       'MjQ+jUiux8vpc8/gj/DgZ8pS6Zmi16jlzpp+Xv6+76SUbrM3cn6F0dKQ8/91XlUEVRpVTqGO5OMBs1plOe+9qQ==');

    ** To open the file, you can access it via FTP.

    Yes, it´s there.
    Jan

    Plugin Author Nagdy

    (@nagdy)

    Well, can you please replace them with a new set of keys from this link https://api.wordpress.org/secret-key/1.1/salt/

    Sorry, it made no difference.
    I will test it on an other domain to see what happens.
    Jan

    It works fine on an other domain on same webhost and server.
    What do you want me to do now?
    Jan

    How come it works on one domain and not on an other? Same webhost, same server…
    Jan

    Plugin Author Nagdy

    (@nagdy)

    Hi Jan,

    Maybe the salt keys on that site are not set correctly.

    What I asked you to do is:

    1- Backup your wp-config.php file.
    2- Delete all keys in the wp-config.php (the keys I mentioned in my first reply).
    3- Go to https://api.wordpress.org/secret-key/1.1/salt/, it’ll generate a unique set of keys for you.
    4- Add them to the config file.

    Now, you’ll need to login again to the site. Once logged in, try the plugin again.

    Exactly what I did, will do it again.
    Will get back to you ASAP.
    Jan

    I uploaded it to an other domain (subdomain) – worked.
    I uploaded it to a new domain – worked.
    So why it doesn´t work on fodelsedagsklubben.com I don´t know.
    Jan

    Plugin Author Nagdy

    (@nagdy)

    This looks weird especially if it is a permissions issue, the plugin should tell.

    One more thing to check, do you have a file called wp-salts.php in your website directory?

    It´s strange, I never get any notification about your replies. Yes, I have checked the box.
    Sorry, where do I find the directory?
    Jan

    Plugin Author Nagdy

    (@nagdy)

    In the same directory where wp-config.php exists. Some hosting providers move the salt keys to a separate file, maybe that is the case with your site.

    Nope, it wasn´t there. Strange thing, when installing Salt Shaker on a subdomain to the main site, it works. And this domain looks like the main domain in the directory.
    I also tried once more to see if Salt Shaker works on fodelsedagsklubben.com. Unfortunately, no difference.
    Jan

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.