WordPress.org

Support

Support » Plugins and Hacks » Uploads by Proxy » [Resolved] Nothing Happening :/

[Resolved] Nothing Happening :/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author pd

    @pdclark

    Do you have permalinks enabled? They are required for WordPress (and the plugin) to intercept image 404’s.

    One quick way to test this is by going to http://localhost:8888/something-that-doesnt-exist. If you get a WordPress 404 template, then that’s working fine. If you get a server/apache 404, then you need to enable permalinks under Settings > Permalinks by selecting any option and clicking “save”. This should save .htaccess and enable the plugin.

    Permalinks are enabled on both the local and remote installs.

    Here’s an example setup:

    I’ve pulled all the recent files (except for uploads) and database to a local install at http://localhost:8888/logos. The remote version is at http://logos-creative.com. I’ve got images loading that exist remotely, but not locally, and don’t load even though I’ve defined define('UBP_LIVE_DOMAIN', 'logos-creative.com'); and activated the plugin.

    Plugin Author pd

    @pdclark

    I’ve worked out that this is caused by the local version being installed in a subdirectory, but the live version being at the root directory.

    I’m looking at solutions now, trying to work out the different possibilities:

    • Local in subdirectory, live in root (and how to catch 404s in this case)
    • Local in root, live in subdirectory
    Plugin Author pd

    @pdclark

    This should be resolved now in version 1.1. Go ahead and give it a try through the WordPress updater.

    Here’s the full changelog.

    Looks like that fixed it for me, Paul! Thanks so much.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Nothing Happening :/’ is closed to new replies.
Skip to toolbar