Support » Plugin: HD Quiz » Nothing at all happens when I hit save question

  • Resolved philrichards

    (@philrichards)


    Save isn’t working at all, I create a question hit save and there’s nothing there on the main screen, the green save button doesn’t even trigger a url or any visible response & just remains green.

    What could the problem be?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Harmonic Design

    (@harmonic_design)

    Hi philrichards,
    You are the first to find this issue, so the problem probably lies with another plugin adding broken or invalid javascript to all pages.

    If the question is successfully saved, then a new section will appear at the top of the page to confirm.

    Can you please tell me what your browser console says? You can access it on most browsers by pressing F12 or CTR + SHIFT + i, but you can also try right-clicking the screen and selecting “inspect”.

    There should be some errors listed that will point us in the right direction.

    Thread Starter philrichards

    (@philrichards)

    Here’s what I get anytime I click the save button..

    https://i.imgur.com/g78fn51.png

    Plugin Author Harmonic Design

    (@harmonic_design)

    Hmmm.. interesting. So something on your site is blocking tinyMCE (which is the default, or “classic” editor) from loading.

    What version of WordPress are you using? Do you have the Classic Editor plugin installed? HD Quiz is fully Gutenberg compatible, so this shouldn’t be an issue.

    The most likely culprit is that you have some other plugin installed that is interfering with the way WordPress native handles enqueued scripts – which is something that no plugin should ever do. It’s also possible that the cause is your theme.

    Please try the default WordPress debug steps.

    1. Temporarily disable all plugins except HD Quiz
    2. Check if saving questions nows works
    1. If it now works, enable each plugin one by one untill you find the poorly coded one
    2. If it does not work, then try temporarily changing your theme to WordPress’ default theme, Twenty Nineteen.

    The above steps will let us know if the issue is with another plugin, your theme, or your WordPress installation

    Thread Starter philrichards

    (@philrichards)

    Sussed out where the issue is.. In Users I had disable the visual editor when writing checked.. I unchecked that and the problem vanished!

    https://i.imgur.com/HOZYGId.png

    I don’t keep it enabled because I enter html in the editor & if I accidentally click on the visual editor it messes everything up. I’ll see what I can do other than disable the visual editor as there’s lots of settings for the tiny editor.

    Thanks for your responses, at least if it crops up again whoever sees this will know where to look.

    Phil

    Plugin Author Harmonic Design

    (@harmonic_design)

    Hi philrichards,
    that is a super interesting cause, and one I would have never even thought of. I guess that setting is a global setting, not just for posts and pages, but even affects custom tinyMCE calls.

    I’ll do the following for the next release of HD Quiz.

    1) I’ll see if there is a way to check that setting, and if it’s enabled, revert to a “simple” editor or similar.
    2) I’ll look further into this, as I feel that your situation/use case is an oversight that the WordPress core team might be interested in. I do not think that the setting should dequeue tinyMCE globally when it was explicitly called, so this might be something that can be fixed within the WordPress core.

    Please let me know if you need any further assistance, and have a great weekend!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Nothing at all happens when I hit save question’ is closed to new replies.