Support » Plugin: WP Store Locator » Not working yet (map not loading/API usage limit)

  • Resolved milauskas

    (@milauskas)


    Hi,

    I’m building a site for a client and right now it’s on my testing server. Perhaps I don’t understand everything required to get the store locator to work but here’s my situation.

    I got browser and server API keys. They’re for my own domain now (not the client’s).

    I plugged those in and then set up one store location.

    When I go to the page with the store locator on it I get an error saying “API limit reached.” I can dismiss that alert but then when the map appears there’s another alert saying “This page can’t load Google Maps correctly.”

    Am I missing something in my settings? Thanks.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    See this answer.

    Thread Starter milauskas

    (@milauskas)

    HI Tijmen,

    We’ve enabled billing but I’m still getting the same errors. API usage limit reached, etc. I’ve even gone through the process of creating new keys but it isn’t working. Am I missing something?

    Note that I DID get the IP address warning when first setting up the plugin. I changed the IP address in the google maps account from my hosting account IP to the one that was shown in the error message and no longer received that error. However, I’m stumped as to why I’m still getting the usage limit error.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    The limit error indeed still shows up on the page and in the browser console.

    If you have enabled billing, then you will have to contact billing support.

    Thread Starter milauskas

    (@milauskas)

    Hi Tijmen, I did contact Google billing support. Here is the reply I got:

    —–
    This is Rob with Maps Platform Support. Looking at your site, I see that the URL you are using to load the JS API is the following:

    https://maps.google.com/maps/api/js?language=en&region=us&key=AIzaSyDkB1m_nXuJtxnX9xMR1lawvabLrY4jX14&v=3.33&key=AIzaSyAJlQAZnvb2xFC5vwBWDKfTFC4rLfDDqK8

    Please note that this URL has two key parameters when it should only have one. The issue is the second key which is coming from a project that doesn’t appear to belong to you and is not associated with a valid billing account.
    —-

    This was my reply: (note that I made a mistake and that, yes, ONE of the keys is one I created)


    Thanks, Rob. I am using a wordpress plugin called WP Store Locator. I am supposed to create 2 Google API keys, one is a “browser key” with restrictions set to my domain. The second is a “server key” with restrictions set to an IP address. It doesn’t look like either of the ones I’m using is what appears in that code you sent me (https://maps.google.com/maps/api/js?language=en&region=us&key=AIzaSyDkB1m_nXuJtxnX9xMR1lawvabLrY4jX14&v=3.33&key=AIzaSyAJlQAZnvb2xFC5vwBWDKfTFC4rLfDDqK8)

    What I have is: browser key: AIzaSyDkB1m_nXuJtxnX9xMR1lawvabLrY4jX14 and server key: AIzaSyClBp9076AC8hs0gJQk_pThJNJOmfFJT3w

    Am I creating these incrorectly? Am I maybe in the wrong area? I am logged into my google account as LesJardins when I create them. And we’ve enabled billing. I even created NEW API keys AFTER we enabled billing just to be sure they were associated with the billing account. I’ve gone all through the support articles and I don’t see anything I’m doing wrong. If you can point me in the right direction that would be great. Thanks!

    So can you tell me why a different second key is showing up in the google maps URL even though I entered the 2 I created just like your tutorial shows? Or as Rob wrote, I should only have ONE perameter? I tried to follow your tutorial exactly so I don’t know where I’m going wrong. Thanks@

    Plugin Author Tijmen Smit

    (@tijmensmit)

    You should not share your API keys here if you didn’t set a referrer for the keys.

    Both keys probably show up due to a conflict with another plugin / your theme.

    Can you enable the compatibility mode on the settings page ( tools section ), and disable all the others plugin and your current theme for a second and see if that fixes it?

    You don’t happen to be using custom code in the functions.php inside your active theme folder to modify anything related to the store locator.

    Thread Starter milauskas

    (@milauskas)

    Yes, I knew I shouldn’t have shared the keys. I can go and delete/change them. I haven’t done anything to functions.php (but I’ll double check). Thanks for the reply and info. I’ll check the plugins too and let you know.

    Thread Starter milauskas

    (@milauskas)

    Compatibility mode was already checked so I left it checked. I disabled all plugins except store locator and I still get the same problem. API usage limit reached.

    Let me ask this: in the instructions for creating a browser key you have “*.example.com/*” so originally I typed in “*.mydomain.com/*”. But I see on Google it has the examples preceded by http or https. I just checked mine to http://*.mydomain.com/* Is this correct?

    I’m just trying to eliminate anything that I may have done wrong when setting things up.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    If you use a subdomain then it should be *.domain.com/* otherwise use domain.com/*

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not working yet (map not loading/API usage limit)’ is closed to new replies.