WordPress.org

Support

Support » Plugins and Hacks » WP Multi Network » Not Working with WP 3.5

Not Working with WP 3.5

  • Hi,
    Greeting of X-Mass,

    I am using WP 3.5 single network by enabling multi-site. Now I tried to Create “Multi-network” having “Multi-site” in each network.

    I use “wp-multi-network”. But I am not able to add new network. It show nothing when i click “Create Network”. No Any Message either site created or any error.

    When I goto “All Networks” it show single (Default) Network only. And when i Click “ADD NEW” it show message like “Cannot load add-new-network”.

    Is there any hope?

    Plz Provide me some help regarding this,

    Thanks to all “Poeter of WordPress”.

    http://wordpress.org/extend/plugins/wp-multi-network/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Please use the code under development in trunk until the latest release is complete

    Hi Ben

    Just tried the development version. Still issues: new blog is correctly added to a new network, but assign sites functionality does not work (“no blog selected”). Also, when viewing the blog, no images get shown and the wp-admin for that blog creates an endless loop.
    Erreur 310 (net::ERR_TOO_MANY_REDIRECTS)

    Hmm, I had that same issue with the redirects on my local dev server. I think it has something to do with DNS or Apache config. It works just fine on my production server though

    Plugin Author David Dean

    @ddean

    Hi all –

    Please use version 1.1 until a new release comes out. This plugin has been undergoing a complete rewrite, so there are many gaps in the development version (like whole admin pages that are blank and functions that don’t do anything) making it unsuitable for production use right now.

    If you are using the dev version, feel free to create topics for issues you find. We are working to patch things up, but this will take time.

    Thank you!

    @david – Should I not be creating/submitting packages then? Where is dev happening? Need any additional help?

    If the latest release is not complete, why has it been released? I think you should at least have some kind of warning in the plugin description, not to use this plugin on production sites.

    @jazbek it has not been released yet, thus the wonky current version. If you look at the code in trunk you can find a more completely working version that is currently in development. I agree that a notice in the description would be nice, however it is not the fault of the plugin that it does not work well with 3.5. There were some structural core changes with 3.5 that the plugin authors are currently working to accommodate.

    To the devs… can we have some more transparency about this project? There are a lot of us users out here. If you need any help there are also plenty of devs willing to toss hours at resolving the issues to make it a good stable plugin again.

    If it wasn’t released, then why is it available for download on the plugin home page? I think that counts as releasing it.

    And it might not be the plugin’s fault (as you say) that it’s not compatible with wp 3.5, but since it’s not, it shouldn’t be listed as compatible with wp 3.5 on the plugin page.

    I think this would be solved by fixing the plugin header in the readme.txt, i.e. the “Stable Tag” header should be 1.1 instead of 1.3.1.

    http://wordpress.org/extend/plugins/about/svn/

    Just sayin!

    True, that number is actually being picked up from the dev version of the readme.txt file. That should be updated for sure.

    And you are looking at an older release :P.

    I’m sorry but this is totally ridiculous. If your going to release a plugin, surely it has to work with WordPress.

    You say to use 1.1 if your on WP 3.5, well I have done, activating the damn thing but nothing happens. I don’t even get the Create Network button.

    I’m trying not to get frustrated, but it seems with everything with WordPress its a bloody nightmare and mine field.

    Please do not use the forum only to vent your frustration, but bring facts that can elucidate any issue you encounter, like the setup and configuration of your system. Do not underestimate the complexity the Multisite mode adds to WP. All this is provided for free and opensource.

    I am aware of that, I’ve not gone too far or personal. Whether or not its free or not, its still out there in the public domain for people to use in their projects.

    I’m also not underestimated the complexity of the plugin, I know how complex these plugins are, but the installation steps on the plugin page allude to the fact that it is anything but complicated.

    That being said I need to give you some information of my setup.

    First of all I am testing this out locally using MAMP Pro. I have the latest version of WordPress 3.5.1.

    I have installed the current version of WP Multi Network and the link appears where I can view My Networks but I get a blank page within the main content area of the admin screen.

    So I uploaded the other 2 released versions, and I don’t even get the My Networks link in the Dashboard.

    ha ha, love it.

    This plugin does the same thing and works: http://wordpress.org/extend/plugins/networks-for-wordpress/

    Does it? Doesn’t seem to be.

    Ok, this is my scenario.

    I have master site, call this Star Wars Universe
    Within that I have sites called:

    Empire
    Jedi Order
    Republic

    Now within Jedi Order for example I want:

    Jedi Temple
    Jedi Knights

    Can this plugin do that? Because it doesn’t seem to be able to.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Not Working with WP 3.5’ is closed to new replies.
Skip to toolbar