Support » Plugin: URL Coupons for WooCommerce » Not working with woocommerce’s geolocation (with page caching support)

  • Resolved wearedigito

    (@wearedigito)


    I tried troubleshooting with all options and it don’t work.

    Example: If URL is domain.com/?promocode=cny22&v=0f177369a3b7 upon load, clicking anything will bring it to https://melatidrinks.com/?v=0f177369a3b7 (removing the delay coupon I suppose?)

    For current setting, loading into page don’t leave the ?promocode=cny22, is there a workaround for this?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @wearedigito,

    I’ve just tested it on my server, but unfortunately, wasn’t able to reproduce the issue – even with “Default customer location” set to “Geolocate (with page caching support)”, URL coupons are still working fine here. Could you please post screenshots of our plugin settings on your site (you can send it directly to tom@anbinder.me), so I could try to replicate it here?

    As for the disappearing promocode URL param – that’s expected. If our plugin finds this param in the URL, it applies (or delays) the coupon, and removes the param from the URL, so this is normal behavior.

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    If anyone else is interested – after some investigation, I believe that the problem is in server-side caching, i.e. it’s not related to the geolocation.

    Solution #1 (easy one; confirmed)

    This is not an ideal solution, but it seems to solve the problem. As usually caching is not done for the cart, checkout, etc. pages, I’ve tried applying the coupon via one of those pages, i.e. if you apply coupon via e.g. https://example.com/cart/?promocode=cny22 (and not https://example.com/?promocode=cny22) – it’s working normally – after I add the product to the cart, I can see that the coupon was applied.

    Solution #2

    Somewhere in your hosting panel, there should be something related to enabling/disabling server-side caching. The most obvious choice – disable server-side caching all at once. And more correct approach would be to configure server-side caching in such a way, that it wouldn’t serve cached pages if there is promocode parameter in the URL.

    P.S. I’m going to mark this thread as “resolved” for now, hope that’s ok. Please let me know if there are still any questions/issues.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.