Support » Plugin: Pin It Button On Image Hover And Post » Not working with W3 TC enabled

  • Hi there,

    I actually have 2 problems.

    I have recently installed and enabled W3 Total Cache, and the Pin It button has disappeared. I was previously using Wordfence Falcon Engine, which has now been discontinued, but the Pin It button was working with Falcon.

    Also, when the Pin it Button was still there and was pressed, the image did not fill the frame. I also still have ‘Simple Light Box’, and when the image is first selected and opened in the light box, and the Pin It button is then pressed, the image now fills the frame.

    My website is: http://www.thetravellingchilli.com As of posting this, W3 TC and this Pin It plugin are both active.

    I hope I make some sense, looking forward to finding a solution.

    Thanks,
    Sean.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I should add, that as far as I know, W3 does not server you cached pages if you are logged in as a WP admin, and yet this Pin it button still does not work.

    Plugin Support Weblizar

    (@weblizar_support)

    hello sean-h,
    is the plugin “pinterest” working when you de-activate the W3 cache plugin??
    Thansk.

    Yes, it works, when I disable just the minify option in W3. When minify is enabled, it does not show the Pinterest button on hover, but it does show the Pinterest button at the bottom of the post. However, at one point, with minify enabled and you clicked on the Pinterest button at the bottom of the post, it redirects in the same tab to a fairly empty page at pinterest.com with something to create new pin.

    As it is right now, minify is enabled and the Pinterest button is showing but only at the bottom of the post, and clicking on it shows the options to pin as it should.

    So it would seem there is a conflict with minify in W3. I can’t actually notice a difference in speed, so perhaps I can disable minify, for now?

    Many Thanks,
    Sean.

    Mr.Lovebucket

    (@mrlovebucket)

    You can also exclude the dedicated .js or .css file from being minified.

    In W3TC “General setting” change minify mode from “auto” to “manual”.
    In the “minify” settings tab scroll down to the “Advanced” section.
    Just enter the url to the file in the appropiate “Never minify the following…”-box

    That’s it.
    Works like a charm.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working with W3 TC enabled’ is closed to new replies.