Support » Plugin: Gallery Custom Links » Not working with Virtue Masonry Gallery

  • Resolved discsox

    (@discsox)


    Thank you for your plugin.
    Unfortunately links do not work with Virtue Galleries from Kadence Themes (see Example).
    I did create a new page, cleared the cache, added new images to the gallery, but clicking an image always just opens the gallery image instead of the link.
    In order to make my pages work I had to revert to “WP Gallery Custom Links” a plugin that has been removed from WP as you are aware, I am sure.
    So I don’t have an active version of your plugin on my site right now. In case you need testing, I can temporarily activate the Gallery Custom Links plugin.
    Gallery is used on the home page of e.g. [ redundant link removed ]

    Kadence themes are pretty popular, Virtue (free version) has over 50k installs for example.

    Hope you have some suggestions or can update your plugin.

    [ Signature deleted ]

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hi,

    Indeed, thanks for the links, I could check and I understand why it doesn’t work. Gallery Custom Links only analyzes HTML elements (galleries) which contain specific CSS classes.

    Could you try to modify the plugin? In the file mgcl_core.php, look for:

    foreach ( $html->find('.wp-block-gallery img') as $element )
      $this->linkify_element( $element );

    And right below those lines, add this:

    foreach ( $html->find('.kad-wp-gallery img') as $element )
      $this->linkify_element( $element );

    If you don’t know how to do that, please contact me here:
    https://meowapps.com/contact

    • This reply was modified 3 months ago by  Jordy Meow.
    discsox

    (@discsox)

    Hi Jordy,
    Thank you VERY much for your reply. I will test this in the next 24h and let you know that results.

    Thanks again for looking into this.

    Kind regards,
    Marcel

    discsox

    (@discsox)

    Hi Jordy,

    I changed the plugin code, disabled the “WP Gallery Custom Links” plugin, enabled your plugin, cleared all the cache in WP, browser etc.
    Unfortunately the links still go to the images.
    I also looked at your code and it should work but i have limited debug capabilities.

    Please let me know in case you have any other ideas.

    thank you and kind regards,

    Marcel

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @discsox,

    Please try the latest version of the plugin, applying the changes I told you earlier (which has not been added to that latest version).

    If it still doesn’t work, please contact me here:
    https://meowapps.com/contact

    I will provide you a fresh environment to replicate the issue, and I will make sure it works on it, and release a new version that works for you 🙂

    discsox

    (@discsox)

    I contacted you via meowapps.com/contact
    thank you again for your support
    kind regards,

    Marcel

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.